Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#110 closed bug (fixed)

StyledEdit doesn't save a file successfully on Haiku

Reported by: korli Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

StyledEdit on Haiku doesn't save with success a file: launch "StyledEdit ~/config/settings/kernel/drivers/kernel" make some changes and save. launch again : no changes saved.

As it happens only on Haiku, it could be related to storage kit or kernel side.

Change History (17)

comment:1 Changed 14 years ago by jackburton

Works well, instead, with a file created with StyledEdit itself.

comment:2 Changed 14 years ago by korli

Maybe add status check on calls of status_t StyledEditWindow::Save(BMessage *message) as it must return silently an error somehow. Then something could be wrong in storage kit, who knows ...

comment:3 Changed 14 years ago by korli

Status: newassigned

comment:4 Changed 14 years ago by korli

Owner: changed from sikosis to jackburton

comment:5 Changed 14 years ago by korli

Another weird testcase: cp config/settings/kernel/drivers/kernel ./ head kernel StyledEdit kernel => modifies a comment at the top of the file then quits with saving head kernel

The file is empty, though filesize isn't zero. Then "StyledEdit kernel" shows bad data.

comment:6 Changed 14 years ago by daneel@…

Can be a problem with SYNC ?

comment:7 Changed 14 years ago by jackburton

I can't reproduce. Maybe your image/partition is corrupt ?

comment:8 Changed 14 years ago by korli

I tried again with http://www.schmidp.com/public/haiku/images/rev16260_raw.tar. bz2 in QEmu and it actually failed often but not everytime. Could be a cache or fs problem after all.

comment:9 Changed 14 years ago by jackburton

Reassigning, as it's most probably a kernel/FS problem

comment:10 Changed 14 years ago by jackburton

Component: ApplicationsKernel

comment:11 Changed 14 years ago by jackburton

Owner: changed from jackburton to axeld

comment:12 Changed 14 years ago by jackburton

Status: assignednew

comment:13 Changed 13 years ago by axeld

Can someone still reproduce this one with a release after 16557?

comment:14 Changed 13 years ago by axeld

Fixed in hrev16613. vm_cache_resize() didn't always work correctly.

comment:15 Changed 13 years ago by axeld

Status: newclosed

comment:16 Changed 13 years ago by axeld

Resolution: fixed

comment:17 Changed 13 years ago by korli

Tested ok, thanks!

Note: See TracTickets for help on using tickets.