Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11088 closed bug (fixed)

locating source in Debugger doesn't work anymore.

Reported by: pulkomandy Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11160
Has a Patch: yes Platform: All

Description

Possibly since the introduction of query-based search of source files, clicking the "click here to locate..." in Debugger doesn't do anything anymore.

I have a volume with queries disabled hosting all my sources. My system volumes has some BFS errors, which may lead to failed queries. But I would expect the file panel to come up despite of this.

Attachments (1)

11088.patch (1.6 KB) - added by anevilyak 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by anevilyak

I can't reproduce this behavior here. In any case, when you click, a background worker is spawned which attempts to perform the actual queries. In case of failure, the volume in question is simply skipped. After said worker completes, it sends a message to the window with the results, which then builds the menu (including an item to locate the file manually). If no results are returned, it falls straight through to the file panel as before. This seems to imply that in your case said worker is either never completing (i.e. hanging inside a query), or hitting an error in an unexpected place such that it never sends a message to the window. Without being able to reproduce it though, I'm not really sure as to where things might be going wrong.

Changed 5 years ago by anevilyak

Attachment: 11088.patch added

comment:2 Changed 5 years ago by anevilyak

Has a Patch: set

comment:3 Changed 5 years ago by anevilyak

Please see if the attached patch makes any difference to your situation.

comment:4 Changed 5 years ago by anevilyak

Resolution: fixed
Status: newclosed

Fixed in hrev47688.

comment:5 Changed 5 years ago by anevilyak

Blocking: 11160 added

(In #11160) Duplicate of #11088.

Note: See TracTickets for help on using tickets.