Opened 5 years ago

Closed 5 years ago

#11087 closed bug (fixed)

Characters on serial port are buffered with a buffer of size 8.

Reported by: pulkomandy Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/TTY Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a small test on a microcontroller. It just sends a single char to the USART every 1.4 seconds.

This works fine in minicom on Linux. On Haiku, both with SerialConnect and Minicom, characters don't get displayed immediately, I have to wait for the microcontroller to send 8 of them before they are processed and read() on the serial port returns.

I tried both a Silicon Labs and a Prolific usb serial converter. Both have the problem. I don't know if the problem is in the TTY layer or the common code in the USB driver.

Change History (3)

comment:1 by pulkomandy, 5 years ago

Today I tested with a CDC device and this one works fine. So it seems the TTY layer and BDataIO stuff are working ok. The problem is either in the usb-serial driver or maybe in the recent changes to uhci.

comment:2 by bonefish, 5 years ago

Owner: changed from bonefish to nobody
Status: newassigned

comment:3 by pulkomandy, 5 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev47717.

Note: See TracTickets for help on using tickets.