Opened 4 years ago

Closed 7 days ago

#11114 closed bug (fixed)

Text does not render in WebPositive with subpixel antialiasing on.

Reported by: jjido Owned by: jua
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: stippi
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The left menu on the following page: http://www.haiku-os.org

Do not render with the following text rendering settings in Appearance: Antialiasing - Glyph hinting: Monospaced fonts only Antialiasing type: LCD subpixel

Attachments (1)

web+ white text.jpeg (317.3 KB) - added by jjido 4 years ago.
sample page with non-rendered text

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by jjido

Attachment: web+ white text.jpeg added

sample page with non-rendered text

comment:1 Changed 4 years ago by jjido

The OS version is hrev47659

comment:2 Changed 4 years ago by diver

Component: Network & InternetApplications/WebPositive
Keywords: webpositive antialiasing removed
Owner: changed from nobody to pulkomandy
Platform: x86All
Status: newassigned

comment:3 Changed 4 years ago by pulkomandy

Cc: stippi added
Component: Applications/WebPositiveServers/app_server

WebKit isn't doing anything special with this, so it must be a problem in app_server. Maybe we missed yet another codepath with the recent clipping changes?

comment:4 Changed 4 years ago by stippi

It does sound like the problem is very likely in the text rendering code path when there is an alpha mask.

comment:5 in reply to:  1 Changed 4 years ago by jjido

Replying to jjido:

The OS version is hrev47659

This still occurs with hrev47849.

comment:6 Changed 3 years ago by pulkomandy

Owner: changed from pulkomandy to jua

comment:7 Changed 7 days ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Seems to work now.

Note: See TracTickets for help on using tickets.