Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#11118 closed bug (fixed)

http://www.planetvb.com/ crashes WebPositive (SSE2 instruction)

Reported by: MatejHorvat Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #11219, #13910 Blocking:
Has a Patch: no Platform: All

Description

Is it because of the CPU (AMD Athlon XP)? The crash report says "invalid instruction". It worked fine in alpha 4.1 (although it didn't render correctly), but now it doesn't in hrev47617.

Attachments (2)

WebPositive-2582-debug-12-08-2014-11-41-07.report (36.2 KB ) - added by MatejHorvat 5 years ago.
WebPositive-959-debug-03-09-2014-10-04-10.report (42.5 KB ) - added by MatejHorvat 5 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by anevilyak, 5 years ago

Component: - GeneralApplications/WebPositive
Owner: changed from nobody to pulkomandy

comment:2 by pulkomandy, 5 years ago

I can't reproduce this in HaikuWebKit 1.4.3. Which version are you using?

comment:3 by diver, 5 years ago

Judging from debug report it's libWebKit.so.1.4.0.

comment:4 by MatejHorvat, 5 years ago

Just updated to the latest version and it still crashes, but apparently for a different reason. With the debugger, I looked at the memory pointed to by EIP and http://onlinedisassembler.com/ tells me that the instruction causing the crash is "movsd xmm0, QWORD PTR [ebx+ecx*8]", which is a SSE2 instruction and not supported on this CPU.

comment:5 by pulkomandy, 5 years ago

Summary: http://www.planetvb.com/ crashes WebPositivehttp://www.planetvb.com/ crashes WebPositive (SSE2 instruction)

comment:6 by pulkomandy, 5 years ago

Blocked By: 11219 added

comment:7 by pulkomandy, 5 years ago

Hi, I think HaikuWebKit version 1.4.6 should work fine again on machines without SSE2. Can you test it?

comment:8 by MatejHorvat, 5 years ago

Sorry for the delay. It does work without SSE2, but I also wanted to test it on a Pentium MMX to see whether it works without any SSE support (and should also without MMX if the goal is still Pentium compatibility), but couldn't because of hardware problems. If it does, then this ticket can be closed. Thanks!

comment:9 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

We do require MMX. I'm not sure about SSE, but on such old machines I would suggest installing an alternative browser such as NetSurf anyway (if you can even get Haiku to boot - it needs 128MB of RAM now which is not that common on non-SSE machines)

Thanks for testing!

comment:10 by MatejHorvat, 2 years ago

Not sure whether this should be a new ticket or not, but HaikuWebKit 1.6.0 and newer require SSE2 again. This time, the crash is in WTF::currentTime, so WebPositive doesn't even open.

comment:11 by pulkomandy, 2 years ago

Blocked By: 13910 added

comment:12 by pulkomandy, 2 years ago

Are you sure it is the same problem? Have you checked in the disassembler that the crash is really on a sse2 instruction?

comment:13 by MatejHorvat, 2 years ago

Yes, it's actually the same as in #13600 (sorry, didn't see that before).

comment:14 by ThomasWinwood, 2 years ago

CC me.

Note: See TracTickets for help on using tickets.