Opened 5 years ago

Closed 5 years ago

#11219 closed bug (duplicate)

WebPositive crash - Unable to retrieve disassembly for IP 0x909b09: No such file or directory

Reported by: un_spacyar Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11118
Has a Patch: no Platform: x86

Description

WebPositive crashes with some sites, always with the follow debug info:

Active Threads:

thread 10316: pthread func thread 10318: w>Downloads thread 10320: w>Settings thread 10324: w>WebPositive: Save thread 10326: timer thread thread 10328: w>OSNews is Exploring the Futur thread 10329: pthread func thread 12537: team 10313 debug task thread 10313: WebPositive (main)

state: Exception (Invalid opcode exception)

Frame IP Function Name ----------------------------------------------- 0x71551648 0x1ca409 ?

Unable to retrieve disassembly for IP 0x1ca409: No such file or directory

This error appears, for example, searchig in Google.com; but I also I get it with some others sites.

hrev 47792 x86_gcc2

Attach several debug reports.

Attachments (5)

Change History (10)

comment:1 by anevilyak, 5 years ago

I'd guess JavaScriptCore is generating assembly that uses SSE opcodes that your CPU doesn't support.

comment:2 by pulkomandy, 5 years ago

I had asked the WebKit devs about this, and they told me JavaScriptCore doesn't generate SSE2. So I'm not sure that't the problem (but it may have changed since then). The fact that Debugger only says "Unable to retrieve disassembly for IP 0x1ca409: No such file or directory" and doesn't give a disassembly makes it difficult to know what the exact instruction was.

comment:3 by korli, 5 years ago

The code seems located in this area, not that it helps a lot.

ID      Base        End         Size (KiB)  Protection  Locking         Name
--------------------------------------------------------------------------------
375625  0x001c1000  0x001cd000          48  rwx         full            mmap area

comment:4 by MatejHorvat, 5 years ago

This might be a duplicate of #11118. The debug reports are similar (we even have the same CPU) and the problem happens to me on many sites too. Clearly JavaScriptCore started using SSE2 instructions somewhere between alpha 4.1 and now.

comment:5 by pulkomandy, 5 years ago

Blocking: 11118 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.