Opened 13 years ago

Closed 13 years ago

#1113 closed bug (duplicate)

Input server and devices should be ready for user input before launching Tracker (and friends)

Reported by: jonas.kirilla Owned by: axeld
Priority: normal Milestone: R1
Component: System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It's contrary to a feeling of responsiveness, and it could be considered rude, to present a mouse pointer on screen, that you can't move, no matter how vigorously you shake your input device. Especially if Tracker and Deskbar are already loading and are visible on screen. That's not a good user experience. The user should be in command, or at least think he/she is.

The system should try to init PS2, USB and other input devices first, then launch app_server and input_server, in rapid succession, and only then, when the mouse pointer is ready to be moved, continue launching the rest of the system.

I believe that this would improve the user experience, even though in real numbers the lessened concurrency might delay the boot process a little.

Change History (3)

comment:1 by jonas.kirilla, 13 years ago

I suppose that is what this Bootscript line is for:

waitfor _input_server_event_loop_ # wait for input devices

Does it work as intended in Haiku?

comment:2 by axeld, 13 years ago

Type: enhancementbug

The thread is started before the input devices are ready. I consider the current behaviour a bug, anyway.

comment:3 by korli, 13 years ago

Resolution: duplicate
Status: newclosed

Dup of #917

Note: See TracTickets for help on using tickets.