Opened 13 years ago

Closed 10 years ago

#1116 closed bug (fixed)

Wrong default application for a preinstalled picture (-j2 build)

Reported by: korli Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I preinstalled (with UserBuildConfig script) the following picture http://jerome.duval.free.fr/00660_splash_1920x1200.jpg on Linux.

Launch with qemu. Open Home with Tracker. Double-click on the picture file. MediaPlayer opens up. I tried "listattr 00660_splash_1920x1200.jpg" and nothing was returned.

Change History (8)

comment:1 by axeld, 13 years ago

I tried to reproduce the problem from a BeOS build (by manually removing the BEOS:TYPE attribute), but when I double click the file, it's correctly identified as image, and ShowImage comes up - furthermore, Tracker *always* calls update_mime_info() on a file when you double click it or move it around; therefore, it should also have a BEOS:TYPE attribute afterwards.

comment:2 by axeld, 13 years ago

It even works when I do a "chmod 444" before opening it - I'm a bit out of ideas. Is it a GCC 4 build?

comment:3 by korli, 13 years ago

Yeah it's a GCC4 build.

comment:4 by korli, 13 years ago

Cc: bonefish added
Component: Kits/Storage KitBuild System
Owner: changed from axeld to bonefish

AFAIT it seems related to the jam command I use : "jam -j2 haiku-image". Tested without -j2 and it works fine. Ingo, is there a known issue with jam -j2 ?

comment:5 by korli, 13 years ago

Cc: bonefish removed

in reply to:  4 comment:6 by bonefish, 13 years ago

Summary: Wrong default application for a preinstalled pictureWrong default application for a preinstalled picture (-j2 build)

Replying to korli:

AFAIT it seems related to the jam command I use : "jam -j2 haiku-image". Tested without -j2 and it works fine. Ingo, is there a known issue with jam -j2 ?

Yep, building with -j2 never worked correctly, AFAIK (it even just failed the last time I tried). The reason might be that the attribute emulation layer under Linux is not thread/process save. I've never tried -j2 under BeOS, though.

comment:7 by jackburton, 10 years ago

I think this can be closed, no ?

comment:8 by axeld, 10 years ago

Resolution: fixed
Status: newclosed

I would guess so.

Note: See TracTickets for help on using tickets.