Opened 12 years ago

Closed 12 years ago

#1117 closed bug (fixed)

Opening and closing multiple instances of Terminal slows system to a crawl.

Reported by: gotaku Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc: bonefish
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Opening something like 10 instances of Terminal don't seem to cause any problems, but once you start closing them the system slows considerably to the point when the 10th one is closed, just moving the mouse shows 100% CPU usage in Pulse.

Looking at the Process Controller the app_server, input_server and DeskBar show a lot more activity than normal.

Change History (3)

comment:1 by bonefish, 12 years ago

Cc: bonefish added
Component: - GeneralServers/app_server

I can reproduce this under VMWare. For the full fun I need to press Alt-N until I've got 25 Terminals and then close them again.

Probably an app server problem, e.g. a region not being cleared correctly, getting more complex when closing windows.

comment:2 by mmlr, 12 years ago

This seems to be the same as #1301 and I think the reason was just found by Jonas Sundström on the development mailing list: http://www.freelists.org/archives/haiku-development/02-2008/msg00033.html

Caused by a large freelist and PARANOID_KFREE src/system/kernel/heap.c:623

comment:3 by mmlr, 12 years ago

Resolution: fixed
Status: newclosed

Should be "fixed" in hrev23879. Actually it was by design and a feature used for debugging. It is now only used conditionally though so it doesn't take down the system. The real fix is moving to a new allocator which does this more efficiently.

Note: See TracTickets for help on using tickets.