Opened 5 years ago

Closed 5 years ago

#11203 closed bug (invalid)

lenovo ideapad s415 U盘 启动死机

Reported by: dxqwx1 Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

About Atheros Wifi Driver Prototype:

WiFi-card driver (GCC2) for the atheros chipset from FreeBSD without any major changes to its codebase (had to move some interrupt handler code into driver-specific glue code).

The atheros driver should support every atheros chipset, which are supported by the FreeBSD driver (look in the corresponding FreeBSD manpage for more information on supported chipsets).

The driver-binary has a size of 500 KiB, due to compiling the WiFi-stack into a static library and statically linking it and the FreeBSD compat layer with the driver

There are no settings to set to make this driver work. Just put the driver in /home/config/add-ons/kernel/drivers/bin and make a symlink to /home/config/add-ons/kernel/drivers/dev/net/ath. A reboot could be required to make Haiku recognize the new driver. X86 64 R47758 硬盘启动死机在第四个图标处 atheros ar9485无线网卡

Change History (4)

comment:1 Changed 5 years ago by diver

The description text is copied from 5 years old article at https://www.haiku-os.org/blog/coling/2009-07-12/wifi_stack_prototype_works. With no syslog or correct description on what's actually going on I'm tempted to close this ticket as invalid.

comment:2 Changed 5 years ago by dxqwx1

关掉这票吧。。。。。系统启动正常了。U盘启动还是奔溃 无线网卡没有工作。。。我再试试 gcc2 系统

comment:3 in reply to:  1 Changed 5 years ago by dillcn

Replying to diver:

The description text is copied from 5 years old article at https://www.haiku-os.org/blog/coling/2009-07-12/wifi_stack_prototype_works. With no syslog or correct description on what's actually going on I'm tempted to close this ticket as invalid.

The bug title is in Chinese, which means that haiku system halted when boot on lenovo ideapad s415 with usb stick.

In description, dxqwx1 said that haiku (X86 64 hrev47758) halted when boot to the fourth icon which indicate boot sequence. May be caused by atheros ar9485 wireless network card.

In comment2, dxqwx1 said that you can close this ticket, haiku system can boot from hard disk, but also crash when boot with usb disk, and wireless network card don't work either.He will try gcc2 version.

comment:4 Changed 5 years ago by waddlesplash

Resolution: invalid
Status: newclosed

Crashing from USB but not from hard disk sounds to me like it's a USB3 issue, which is already a known bug as well. And what GCC was used to build should not matter in this case.

Note: See TracTickets for help on using tickets.