Opened 5 years ago

Closed 3 years ago

#11215 closed bug (fixed)

Webpositive - YouTube crash full screen mode

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Video loads and plays in normal mode. When switched to full screen Webpositive crashes after a few seconds.

Attachments (5)

Jimmy Fallon YouTube Link (83 bytes) - added by vidrep 5 years ago.
WebPositive-740-debug-09-09-2014-01-38-08.report (65.8 KB) - added by vidrep 5 years ago.
screenshot1.jpeg (347.4 KB) - added by vidrep 5 years ago.
YouTube Link (42 bytes) - added by vidrep 5 years ago.
screenshot1.png (231.8 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by vidrep

Attachment: Jimmy Fallon YouTube Link added

comment:1 Changed 5 years ago by anevilyak

Component: - GeneralApplications/WebPositive
Owner: changed from nobody to pulkomandy

comment:2 Changed 5 years ago by pulkomandy

I can't reproduce this. Does it still happen with HaikuWebKit 1.4.4?

comment:3 Changed 5 years ago by vidrep

Using hrev47865 WebKit 1.4.4. No YouTube videos will play now. All videos give the error message shown in the attached screenshot.

Changed 5 years ago by vidrep

Attachment: screenshot1.jpeg added

comment:4 Changed 5 years ago by diver

Weird, the same video works fine here with the same version of WebKit.

comment:5 Changed 5 years ago by vidrep

As an experiment I re-installed hrev47849 x86_gcc2. I went to YouTube and randomly picked a video (link in attachment). It loaded quickly and played smoothly without skipping or freezing in both normal and full screen modes. Next, I updated to hrev47868 using the "pkgman update" command, and verified that WebKit was indeed updated to 1.4.4-3. I played the same clip from YouTube. It took a very long time to start playing. Once started, playback was very jerky and eventually it froze (see attached screenshot).

Changed 5 years ago by vidrep

Attachment: YouTube Link added

Changed 5 years ago by vidrep

Attachment: screenshot1.png added

comment:6 Changed 5 years ago by vidrep

I once again reverted back to hrev47849, and the same clip plays smoothly, as before. However, when I switched to full screen mode it became jerky and then froze.

comment:7 Changed 5 years ago by vidrep

Is this possibly related to ticket #11098?

comment:8 Changed 5 years ago by anevilyak

Not at all.

comment:9 Changed 3 years ago by vidrep

I tried the same link with webkit 1.5.2 hrev50094 x86_gcc2. Full screen mode is not supported by Web+, but theatre mode worked perfectly. This ticket is either invalid or fixed.

comment:10 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.