Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11231 closed bug (fixed)

[WebPositive] "pixelated" rendering of text and freezing while scrolling

Reported by: taos Owned by: jua
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11271
Has a Patch: no Platform: All

Description

Using HaikuWebkit 1.4.4 with hrev47850 gcc2h, I've encountered a website (​http://www.spiegel.de), that looks really strange. In the upper part text is rendered fine: rendering of upper part of www.spiegel.de In the lower part, text seems "pixelated": rendering of lower part of www.spiegel.de With HaikuWebkit 1.4.3 the pixelated texts were missing (there was just a white area). Additionally, if you scroll further down, WebPositive freezes quite often (debug report attached). Most of the time you can reproduce this - at least on my machine - by scrolling down to the pixelated area (sometimes it's already frozen at this point), switch to another tab and go back and try to scroll either using scroll bars or up/down arrow keys.

Attachments (4)

upper_part.png (240.9 KB) - added by taos 5 years ago.
rendering of upper part of www.spiegel.de
lower_part.png (129.8 KB) - added by taos 5 years ago.
rendering of lower part of www.spiegel.de
WebPositive-922-debug-11-09-2014-19-17-34.report (78.5 KB) - added by taos 5 years ago.
report file for frozen WebPositive
c57-blurry-text.png (255.8 KB) - added by jprostko 5 years ago.
Blurry text in admin UI of concrete5 5.7

Download all attachments as: .zip

Change History (19)

Changed 5 years ago by taos

Attachment: upper_part.png added

rendering of upper part of www.spiegel.de

Changed 5 years ago by taos

Attachment: lower_part.png added

rendering of lower part of www.spiegel.de

Changed 5 years ago by taos

report file for frozen WebPositive

comment:1 Changed 5 years ago by jprostko

On hrev47853 GCC2 hybrid with HaikuWebkit 1.4.4, I am seeing blurry text as well in the newly-released concrete5 5.7.0. Essentially you will see blurry text on certain text unless it is hovered over or clicked.

I would file another ticket, but I'm pretty sure this is the same issue as seen on the Spiegel site. If need be, I can set up a test login, as I only see this behavior in the admin UI of concrete5. I will attach an image showing the behavior as well.

Changed 5 years ago by jprostko

Attachment: c57-blurry-text.png added

Blurry text in admin UI of concrete5 5.7

comment:2 Changed 5 years ago by jprostko

Solely as an FYI, this still occurs with concrete5 5.7.1 on a Haiku GCC2 Hybrid, hrev48031, which is using HaikuWebKit 1.4.5.

comment:3 Changed 5 years ago by pulkomandy

The donation meter on haiku-os.org has the same problem. It is related to the use of alpha transparency with clipping, and there is a test case in app_server clipping tests that reproduces it, too.

comment:4 Changed 5 years ago by taos

I still see the same problem with haikuwebkit 1.4.6 on hrev48099 gcc2hybrid.

comment:5 Changed 5 years ago by vidrep

My ticket #11271 is a duplicate of this same issue and can be closed as such.

comment:6 Changed 5 years ago by anevilyak

Blocking: 11271 added

comment:7 Changed 4 years ago by taos

With HaikuWebKit 1.4.9, it seems to be back to 1.4.3's behaviour: instead of pixelated text there's no visible text at all.

comment:8 Changed 4 years ago by taos

Using HaikuWebKit 1.4.10 on hrev48824, I can't see the pixelated look on the homepage of www.spiegel.de anymore. The font of the donation meter on www.haiku-os.org (not the one on www.haiku-inc.org), however, seems to still be affected by this problem. So, I'm not sure if the new version of HaikuWebKit solved (at least a part of) this rendering bug or if www.spiegel.de changed their homepage somehow.

comment:9 Changed 4 years ago by taos

I think the spiegel.de homepage was recently redesigned so that it no longer shows these problems. With HaikuWebKit 1.4.12, there's still invisible text in the lower part of the homepage if an older version of the homepage (e.g. from January 2015) is loaded via waybackmachine. The freezing, however, seems to be gone for good.

comment:10 Changed 4 years ago by vidrep

I had a duplicate ticket #11271. Trying the same webpage today with hrev49717, I do not see the pixelated text. I assume it was resolved sometime in the past year.

comment:11 Changed 4 years ago by taos

The text of the haiku donation meter is still pixelated.

comment:12 Changed 4 years ago by pulkomandy

Owner: changed from pulkomandy to jua
Status: newassigned

comment:13 Changed 4 years ago by jua

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev49807

comment:14 Changed 4 years ago by taos

hrev49822 x86_64 is still on HaikuWebKit 1.4.13, so no change there. With hrev49822 gcc2 hybrid, the haiku donation meter has no pixelated text anymore. This seems to be solved.

The older spiegel.de homepages loaded via waybackmachine, however, still show the same issues. Recent versions of spiegel.de look okay (apart from an encoding(?) problem that results in a question mark in a box instead of an umlaut).

comment:15 Changed 4 years ago by taos

BTW, with HaikuWebKit 1.5.1 on hrev49856, the archived spiegel.de pages are now rendered correctly, too.

Note: See TracTickets for help on using tickets.