Opened 5 years ago

Closed 5 years ago

#11276 closed bug (duplicate)

[ifconfig] can't add interface back after deletion

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: #9594 Blocking:
Has a Patch: no Platform: All

Description

hrev47896.

~> ifconfig 
loop    Hardware type: Local Loopback, Address: none
        inet addr: 127.0.0.1, Mask: 255.0.0.0
        inet6 addr: ::1, Prefix Length: 128
        MTU: 16384, Metric: 0, up loopback link
        Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Transmit: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Collisions: 0

/dev/net/ipro1000/0
        Hardware type: Ethernet, Address: 08:00:27:3a:98:07
        Media type: 1 GBit, 1000BASE-T
        inet addr: 192.168.0.6, Bcast: 192.168.0.255, Mask: 255.255.255.0
        MTU: 1500, Metric: 0, up broadcast link auto-configured
        Receive: 61130 packets, 0 errors, 46401139 bytes, 0 mcasts, 0 dropped
        Transmit: 59534 packets, 0 errors, 6133630 bytes, 0 mcasts, 0 dropped
        Collisions: 0

~> ifconfig del /dev/net/ipro1000/0
~> ifconfig /dev/net/ipro1000/0 up
ifconfig: Could not add interface: General system error

~> ifconfig /dev/net/ipro1000/0 auto-config up
ifconfig: Could not add interface: General system error
~> ifconfig 
loop    Hardware type: Local Loopback, Address: none
        inet addr: 127.0.0.1, Mask: 255.0.0.0
        inet6 addr: ::1, Prefix Length: 128
        MTU: 16384, Metric: 0, up loopback link
        Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Transmit: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Collisions: 0

~> ls /dev/net/ipro1000/0 
/dev/net/ipro1000/0
~> ifconfig /dev/net/ipro1000/0 
/dev/net/ipro1000/0
        Interface not found!

~> ifconfig 
loop    Hardware type: Local Loopback, Address: none
        inet addr: 127.0.0.1, Mask: 255.0.0.0
        inet6 addr: ::1, Prefix Length: 128
        MTU: 16384, Metric: 0, up loopback link
        Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Transmit: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Collisions: 0

Change History (4)

comment:1 by waddlesplash, 5 years ago

Isn't this a duplicate of #9594?

comment:2 by diver, 5 years ago

I'm not sure. in #9594:

~> ifconfig del /dev/net/ipro1000/0
~> ifconfig /dev/net/ipro1000/0 up
ifconfig: Could not add interface: General system error

~> ifconfig /dev/net/ipro1000/0
/dev/net/ipro1000/0
        Hardware type: Ethernet, Address: 08:00:27:b8:ae:41
        MTU: 0, Metric: 0

...and this here:

~> ifconfig /dev/net/ipro1000/0 
/dev/net/ipro1000/0
        Interface not found!

in reply to:  2 comment:3 by jackburton, 5 years ago

Replying to diver:

I'm not sure. in #9594:

~> ifconfig del /dev/net/ipro1000/0
~> ifconfig /dev/net/ipro1000/0 up
ifconfig: Could not add interface: General system error

~> ifconfig /dev/net/ipro1000/0
/dev/net/ipro1000/0
        Hardware type: Ethernet, Address: 08:00:27:b8:ae:41
        MTU: 0, Metric: 0

...and this here:

~> ifconfig /dev/net/ipro1000/0 
/dev/net/ipro1000/0
        Interface not found!

It's definitely a duplicate. The reason you get different output is because we changed ifconfig to spit out an "Interface not found!" message if you call it on a non-existing interface.

comment:4 by diver, 5 years ago

Blocked By: 9594 added
Resolution: duplicate
Status: newclosed

Ok then :)

Note: See TracTickets for help on using tickets.