Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11278 closed bug (invalid)

[Pe] : some keybindings are broken

Reported by: ttcoder Owned by: puckipedia
Priority: normal Milestone: R1/beta1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After upgrading to hrev47850 from 47700-ish range, Pe lost the ability to recognize Alt-Z for Undo, Shift-Alt-Z for Redo, and a couple others. Most of the keybindings still work. Other apps are not affected, only Pe.

Deletings config/settings/pe/keybindings does not fix the problem.

First thought it was a french keymap specific regression, but it occurs also if I change the keymap to US.

The bug is fairly high-profile as it also causes weirdness in the Preferences > Keybindings pane: hitting Alt-Z, the textfield displays Alt-} (curly brace) (?!), hitting alt-B it displays Alt-U (!) and so on for a few others that are no longer mapped correctly.

The Pe package is still 2.4.5 so the breakage might be caused by changes in Haiku itself; filing here rather than github for now.

Might be caused by the keymap-related changes that occured in the Haiku codebase a few weeks ago ?

Change History (7)

comment:1 by anevilyak, 5 years ago

Is it reproducible if you just boot a nightly off a USB stick?

comment:2 by ttcoder, 5 years ago

Hmmmm are keybindings still saved in pe/keybindings or somewhere else ? Quitting it and relaunching Pe I see it has memorized my changes, even though the file's not there:

~/config/settings/pe> ls keybindings
ls: cannot access keybindings: No such file or directory

@evilyak: going to try with an external hard-drive; will take a few days turn-around time

comment:3 by waddlesplash, 5 years ago

Milestone: R1R1/alpha5
Owner: changed from nobody to puckipedia
Status: newassigned

Yes, this was due to https://github.com/olta/pe/pull/13 -- which was supposed to change Pe's keybindings to match Haiku convention more closely. Assigning to Puck so he can have a look at it.

comment:4 by ttcoder, 5 years ago

Weirdness... After rebooting and relaunching Pe I now see a "keybindings-v2" file indeed, and the previous settings file which I had renamed (while Pe was running) is now gone. So 1) it seems version 2.4.5 includes the changes you mentionned Augustin and 2) Pe must have had an entry_ref+file-descriptor "lock" on my old settings file, even after quitting Pe, which was only released after rebooting... Either that or I lack sleep more than usual.

Anyhow this new code indeed does not work here, the "out of the box" keybindings-v2 settings insist on assigning Alt-Y for undo, and if I open the prefs to change that I see the alt-curly-brace, alt-Delete oddities ..etc.

I've found one setting where the mapping is correct, and which is also is kinda acceptable for my muscle memory: Ctrl-Z (instead of Alt-Z... close enough) so using that for now :-)

comment:5 by ttcoder, 5 years ago

Confirming, it seems if I blacklist /system/apps/Pe and use the older Pe binary from an old 2.4.4 package the Alt-Z shortcut can be configured again (going through a few hoops as before, but nothing bad). I'll do that for now. Gotta file a ticket over at github as I now realize it's indeed a regression in 2.4.5, not something that was caused by Haiku. Sorry for the noise.

comment:6 by anevilyak, 5 years ago

Resolution: invalid
Status: assignedclosed

comment:7 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.