Opened 5 years ago

Closed 3 years ago

#11370 closed bug (fixed)

GLTeapot crashes with specific user input

Reported by: mounty Owned by: kallisti5
Priority: normal Milestone: R1
Component: Applications/GLTeapot Version: R1/Development
Keywords: crash Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is reproducible thus:

  • Start GLTeapot
  • Maximise
  • Lights / right / green
  • Effects / Perspective
  • Alt-N
  • Alt-N
  • Effect / fog

About 60% of the time, GLTeapot crashes with the Terminate / Debug / Save-Report dialog but if it doesn't, one or two cycles of:

  • Effect / fog
  • Effects / Perspective
  • Effects / Perspective
  • Effect / fog

will cause it to do so.

Change History (5)

comment:1 by waddlesplash, 5 years ago

Keywords: reproducible removed
Milestone: R1R1/alpha5
Platform: x86All

comment:2 by mmadia, 5 years ago

Milestone: R1/alpha5R1

comment:3 by diver, 3 years ago

Does it still crash? Can't reproduce in vbox at least.

comment:4 by mounty, 3 years ago

No; it no longer crashes. Please close.

comment:5 by diver, 3 years ago

Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.