Opened 5 years ago

Closed 5 years ago

#11395 closed bug (fixed)

New network preflet doesn't log network activity

Reported by: Giova84 Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Network Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

As I can see in the new network preflet, there is a tab called "interface" which shows brief infos about the network connection: there are a pair of entries named "Sent" and "Received" (there is a similar thing in the "NetPulse" application, which distinguishes "Bytes" and "Packets" for send and received), but doesn't show any progress/activity: will always show 0 KBytes. In anyway, before the implementation of the new network preflet, at least "NetPulse" was able to log network statistics: currently, not even NetPulse, is no longer able to log the network activity.

Maybe there is something that should be reimplemented again?

Attachments (1)

Net_Activity.png (220.8 KB) - added by Giova84 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Giova84

Attachment: Net_Activity.png added

comment:1 Changed 5 years ago by diver

NetPulse still works here, it doesn't related to the new network preflet at all. However, it seems that Network preflet doesn't update statistics on the statistics fly as one has to deselect current interface and select it again to update Sent/Received values.

comment:2 Changed 5 years ago by Giova84

Sorry, I assumed that was related, because before updating Haiku to hrev 48167 (with the new network preflet) NetPulse properly showed network statistics. I also tried to delete the setting file of NetPulse but without success. In anyway, you're right: net preflet doesn't update statistics on the fly.

comment:3 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Fixed in hrev48355.

Note: See TracTickets for help on using tickets.