Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11435 closed bug (fixed)

Re: nightly builds not installing anymore since rev. 47853

Reported by: bruno Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Re: nightly builds not installing anymore since rev. 47853

next rev. 47855 wont install anymore...

Attachments (1)

IMAG2033-1-1.jpg (114.0 KB ) - added by bruno 5 years ago.
syslog on screen

Download all attachments as: .zip

Change History (18)

by bruno, 5 years ago

Attachment: IMAG2033-1-1.jpg added

syslog on screen

comment:1 by anevilyak, 5 years ago

Component: - GeneralDrivers/Disk
Milestone: R1/alpha5R1

Looks like you're trying to boot from a CD? Does it work from a USB stick?

comment:2 by anevilyak, 5 years ago

Also, any particular reason you're trying that old of a build? 47853 is over a month ago.

comment:3 by bruno, 5 years ago

Did not try with a usb stick... only with CD All other builds after this wont install... I just tried to find out which was the last working release...

comment:4 by bruno, 5 years ago

I tried the newest build too... I will try to make a usb-stick...

comment:5 by luroh, 5 years ago

Owner: changed from nobody to tqh
Status: newassigned

hrev47855 could possibly be the culprit, assigning to tqh.

comment:6 by bruno, 5 years ago

yes it is very likely that hrev 47855 is the problem! I tried since version hrev.47853 to update to a newer built. I did not file a bug, because I was thinking someelse sure would do so. But after one month now I try to file this bug... To make a usb-stick within Haiku is very easy, but since the new builds wont work I dont like to try it with windows...

What else can I do to help you to find the problem faster?

More Screenshots?

Last edited 5 years ago by bruno (previous) (diff)

comment:7 by humdinger, 5 years ago

This may be related:
I downloaded a raw image (hrev48269), unzipped, and doubleclicked to mount. Installer aborts at file 84 ("Haiku Book"), presenting an alert: "Error: Bad data". The checksum of the archive is OK.

I then tried with the same revision as anyboot image, unzipped, used "diskimage" to register the image, and mounted. Now, the installation ran through successfully.

comment:8 by pulkomandy, 5 years ago

Build log for hrev48269 nightly: http://buildbot.haiku-os.org/builders/haiku-nightlies-x86_gcc2/builds/133 in case there's something relevant there.

comment:9 by bruno, 5 years ago

why nothing happens with this problem?

comment:10 by bruno, 5 years ago

how to use anyboot image for burning a CD?

comment:11 by pulkomandy, 5 years ago

Just burn it on the CD like any ISO image. Some (stupid) burning software will require you to rename it to .iso so they recognize it.

comment:12 by bruno, 5 years ago

ah ok now I burned a CD with anyboot.image and it is working! But install process takes some time after 3rd boot icon... Then it installs as usual...

So problem is the -zip image... ;-)

comment:13 by humdinger, 5 years ago

FWIW, I downloaded a hrev48359 raw and anyboot. Mounted the raw and used Installer to put on a partition. Works. dd'ed the anyboot to a USB stick. Boots. I don't have a CD drive, so I can't test the ISO right now. The problem seems to be solved, right?

comment:14 by bruno, 5 years ago

No idea if the .zip files work now! I used anyboot file... Now I use pkgman for update so I did not try to burn a CD-image with a .zip file since then... Maybe .zip files are absolete now?

Anyboot will do its job... Isnt it?

Last edited 5 years ago by bruno (previous) (diff)

comment:15 by pulkomandy, 5 years ago

Resolution: fixed
Status: assignedclosed

Anyboot is the official image now, the other formats are there for testing and debugging only. So if anyboot is working I think we can close this bug.

comment:16 by luroh, 5 years ago

Blocking: 11666 added

comment:17 by pulkomandy, 5 years ago

Blocking: 11666 removed

(In #11666) #11666 is for tracking problems in a very specific case: things that happen on some nightly builds, but not others, so the error appears and disapears again as you update. Please don't include all "I updated Haiku and it doesn't work now" tickets as blocking this.

The fact that these problems come and go accross revisions makes them harder to track, and points to the issues being related to build-time randomness. For example in the case of #11435, there is an actual bug (the RTF translator trying to handle things it can't do), and the "randomness" making it appear either before or after the StyledEdit translator in the roster depending on how the package was created.

So, this ticket isn't "random things stop working for no apparent reason". It's rather "bug that happens on some nightly build, disappears in the next one, then comes back".

For #11708, there were recent changes to core system parts such as BMessage. If these introduced a bug, it's likely to affect many applications even though their code did not change.

For #11435, the issue is specific to ISO images, with anyboot working ok. No one has seen it go away and reappear.

Note: See TracTickets for help on using tickets.