Opened 5 years ago

Last modified 17 months ago

#11469 reopened bug

Webpositive playing youtube videos restart after ads

Reported by: HAL Owned by: pulkomandy
Priority: normal Milestone:
Component: Applications/WebPositive Version:
Keywords: webpositve youtube adds video restart Cc: HAL
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Playing youtube videos always sends the video back to its start after an add. There is no way to drag the progress bar to the previous position.

Attachments (1)

Haiku Webpositive Crash to KDL.JPG (1.1 MB ) - added by HAL 17 months ago.

Download all attachments as: .zip

Change History (28)

comment:1 by HAL, 5 years ago

I was testing in hrev48301 x86_64

comment:2 by HAL, 5 years ago

The same happens with gcc4 hybrid builds.

Last edited 5 years ago by HAL (previous) (diff)

comment:3 by ttcoder, 5 years ago

Summary: Webpositive playing youtube videos restart after addsWebpositive playing youtube videos restart after ads

Good find, the bug being associated with advertisements seems to tie-in nicely with what I observe here: here the stoppage does not occur with 100% of videos (just like there are ads not in 100% of them), it occurs after a random duration (just like ads are random in duration). It's not a perfect fit though.

comment:4 by pulkomandy, 5 years ago

Are there videos with ads in the middle of them? Are these video ads or just text popups? Could you link to a video where this happens?

comment:5 by waddlesplash, 5 years ago

  1. Yes, but only text ads in the middle of the video and only on the bottom of the player.
  2. Both, but the video ads only play once before the actual video starts.
  3. Sadly no, as YouTube only plays video ads sparsely and so there are no videos that play an ad 100% of the time before showing you a video. However, clicking on random videos on a monetized channel (most of the top 20 or so channels are monetized -- there is a list of these somewhere) will eventually play an ad before the video starts.

Also, what do you mean "the video restarts after an ad"? Ads are really different videos entirely, so if you mean that the counter resets to zero, that's expected. Or do you mean that the counter is supposed to jump ahead to the last time you were looking at (a somewhat new feature of YouTube)?

comment:6 by pulkomandy, 5 years ago

@waddlesplash: I know about those (text ads during video play, video ads at start of a video), however both seem to work fine and "sends video back to its start" makes no sense in that context. Hence I am asking the original poster for more details, maybe because only very long videos can get interrupted by a video ad, or maybe this can only happen in certain countries or depends on some other youtube setting.

Or maybe it's what you say, the video should resume from the middle if you already visited it. In that case I would need to investigate how Youtube is trying to do that.

Waiting for original poster to add more details about what's wrong and what's expected here.

in reply to:  6 comment:7 by HAL, 5 years ago

Replying to pulkomandy:

@waddlesplash: I know about those (text ads during video play, video ads at start of a video), however both seem to work fine and "sends video back to its start" makes no sense in that context. Hence I am asking the original poster for more details, maybe because only very long videos can get interrupted by a video ad, or maybe this can only happen in certain countries or depends on some other youtube setting.

Or maybe it's what you say, the video should resume from the middle if you already visited it. In that case I would need to investigate how Youtube is trying to do that.

Waiting for original poster to add more details about what's wrong and what's expected here.

I am in New Zealand and video adds can start in the middle of a long video. I assumed this happened viewing youtube from anywhere. It can be very annoying because thse ads come quite often in one video. If I view those same videos in Linux Mint 17.1, the video does not reset back to the start but continues from where the ad interrupted. Small text pop-ups don't cause the video to reset to the start. I will try and find an example.

comment:8 by HAL, 5 years ago

I don't know if showing a link to an example will do much good, if the ads don't play in the main video, from the country where the viewer watches from.

comment:9 by HAL, 5 years ago

I am not able to find any example videos with Webpositive. After a few seconds openning youtube home page Webpositive crashes. I will look for example videos with firefox in Linux Mint. I am reasonably sure it happens with every video with ads during playback, so it probably does not matter.

comment:10 by HAL, 5 years ago

Here is a video with five video ads in it. https://www.youtube.com/watch?v=pbcrUPMYlGA

comment:11 by HAL, 5 years ago

Any video over about 30 minutes will have video ads.

comment:12 by pulkomandy, 5 years ago

Ok, I can reproduce this as well on some long enough videos.

comment:13 by humdinger, 4 years ago

All the videos with ads that I could find play fine... Close ticket?

comment:14 by HAL, 4 years ago

Yes I can confirm videos with ads don't reset to beginning of video now.

comment:15 by pulkomandy, 4 years ago

Resolution: fixed
Status: newclosed

Thanks!

comment:16 by HAL, 4 years ago

I did not test properly to say video playback did not restart after ads, It is still doing that. It does it with this youtube video: https://www.youtube.com/watch?v=1kG3Bvrxezc I was testing in hrev109. This in both gcc2 hybrid and x86_64 This bug needs to be reopened.

comment:17 by humdinger, 4 years ago

Seems to depend on the kind of ad that youtube decides to unleash on the user. I tried three times and had to sit through up to 3 minute long spots and the actual video always started as it should. Skipping after some seconds also seems to work.

in reply to:  17 comment:18 by HAL, 4 years ago

Replying to humdinger:

Seems to depend on the kind of ad that youtube decides to unleash on the user. I tried three times and had to sit through up to 3 minute long spots and the actual video always started as it should. Skipping after some seconds also seems to work.

Did you try with the video I gave in the link in comment 16? I have just updated to hrev50127 x86_gcc2 and still happening with at least that video for me. After the second ad it went back to the start. At the 1st ad before the video starts it starts automatically after.

comment:19 by HAL, 4 years ago

A slight error in my last comment: "At the 1st ad before the video starts it starts automatically after." I just tested again. It does not automatically start after the first ad. After the first ad I have to click the start button on the player.

comment:20 by humdinger, 4 years ago

Sorry, you're right. I thought making it thru the 1st ad was the issue. But you're right, after the 2nd ad it reverts back to the start.

comment:21 by pulkomandy, 4 years ago

Resolution: fixed
Status: closedreopened

comment:22 by pulkomandy, 3 years ago

Please test with a recent build, this may be solved.

comment:23 by HAL, 3 years ago

I tested with hrev50679 x86 gcc2 and 64bit. Webpositve in both at the start before actual video plays, when a ad starts first, will go to the end of an ad then just freeze. It is possible to click on skip ad button and it will start playing the actual video. So far I have not been able to fully test again with the latest revisions. Webpositive is crashing so often at partway through a video even before an ad is played near the middle.

comment:24 by vidrep, 3 years ago

This bug was fixed but now has rear it's ugly head again. Web+ crashes at the end of each advert and never gets to the main content. Tested with hrev50677 x86_gcc2.

comment:25 by HAL, 17 months ago

I am testing in hrev52040, now Webpositive will crash if I try and skip the ad. Letting run to the end it will start playing the main content but at least once it has totally crashed partway through main content. When it did that Haiku went KDL but moving my mouse around left traces exposing the desktop underneath. This ruined the KDL screen. If it happens again I will try taking a photo without moving the mouse. In another video it got past the first ad but after playing the second ad it started playing the video from the beginning again, just as before and what this bug is concerned with.

Last edited 17 months ago by HAL (previous) (diff)

comment:26 by HAL, 17 months ago

I have just added the trace of Webpositive crashing to KDL partway through main content after first ad. The trace may not be worth much because it seems to stop before end and there is no way to type "bt". It is just showing some screen output before getting to cursor.

comment:27 by waddlesplash, 17 months ago

That's not a KDL, it's an app_server crash. You can try running "save-report" at the prompt, which will save the debug report on the Desktop.

Note: See TracTickets for help on using tickets.