Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1149 closed bug (fixed)

BeShare crashes when attempting to connect to server

Reported by: koki Owned by: hugosantos
Priority: normal Milestone: R1
Component: Network & Internet/IPv4 Version: R1/pre-alpha1
Keywords: Cc: hugosantos
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Trying BeShare (BeOS build from http://www.bebits.com/app/1330), the application starts, but it crashes when attempting to connect to the server.

Revision 20591 running in free VMWare player 1.03, with NIC configured as ipro1000 (which is detected and works fine with wget).

How to reproduce:

  • Run BeShare
  • Select File > Connect to... menu

Backtrace attached.

Attachments (1)

2007-04-09_beshare-bt.PNG (61.7 KB) - added by koki 12 years ago.
BeShare crash backtrace

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by koki

Attachment: 2007-04-09_beshare-bt.PNG added

BeShare crash backtrace

comment:1 Changed 12 years ago by wkornewald

Owner: changed from wkornewald to axeld

Axel, that's my present for you. :)

comment:2 Changed 12 years ago by wkornewald

Cc: hugosantos added

Hugo, you now have developer access rights. If you want to work on this, please choose "accept ticket".

comment:3 Changed 12 years ago by hugosantos

Owner: changed from axeld to hugosantos
Status: newassigned

Thanks Waldemar. I'm actually working on getting BeShare running. It's almost there.

comment:4 Changed 12 years ago by hugosantos

Resolution: fixed
Status: assignedclosed

This particular issue related with prepend_size has been fixed in revision 20640. Please let me know if additional problems remain.

comment:5 Changed 12 years ago by wkornewald

BTW, could you please use hrev20640, so it gets linked automatically? Thanks a lot for fixing this! :)

Note: See TracTickets for help on using tickets.