Opened 13 years ago

Closed 5 years ago

#1150 closed bug (invalid)

usb stack freezes Dell Latitude D810

Reported by: bryanv Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc: siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Get a Dell Latitude D810

Boot Haiku

if the usb_hid device driver is installed, the machine will freeze (this is the first USB device that inits the bus_manager)

Removing that will get you further along the boot process. Any attempt to access USB will instantly freeze the machine, no KDL.

Attachments (4)

img-1.jpg (385.2 KB ) - added by Adek336 11 years ago.
syslog (5.0 KB ) - added by Adek336 11 years ago.
corresponding part of the syslog when boot succeeds
img_1044-mod.jpg (82.5 KB ) - added by Adek336 11 years ago.
More than 99%: backtrace
img_1045-mod.jpg (35.9 KB ) - added by Adek336 11 years ago.
More than 99%: teams, threads

Download all attachments as: .zip

Change History (20)

in reply to:  description comment:1 by bryanv, 13 years ago

Replying to bryanv:

Get a Dell Latitude D810

Boot Haiku

if the usb_hid device driver is installed, the machine will freeze (this is the first USB device that inits the bus_manager)

Removing that will get you further along the boot process. Any attempt to access USB will instantly freeze the machine, no KDL.

I should add that removing all USB drivers resulted in a perfectly working system.

comment:2 by mmlr, 13 years ago

Status: newassigned

Hi Bryan

Could you check if there is relevant information in the serial debug output and post it here if you find something? I need to know whether some actions are initiated or if it's something with actually loading the stack and drivers.

Regards Michael

comment:3 by korli, 13 years ago

Bryan, could you also make a "listdev" and give info about USB controllers found ?

comment:4 by siarzhuk, 12 years ago

Cc: siarzhuk added

comment:5 by mmlr, 12 years ago

Could you retest with the latest changes? We've changed the usb_hid and the devfs rescan sections quite extensively in the last week. Maybe it fixed or at least changed the behaviour with that?

comment:6 by bryanv, 12 years ago

I wish I could.

However, I no longer have this laptop. It was a machine from my employer, and I've since changed jobs.

I'll see what I can do about finding someone to test it though..

:-(

comment:7 by scottmc, 12 years ago

Anyone else with a Dell Latitude D810 that can do some testing on this?

comment:8 by Adek336, 11 years ago

On a Dell Latitude C800, it fails to boot most of the time (if it boots, it works fine). It either hangs after the third boot icon with F12 not working; blanks the screen and then KDLs (which I know it does, because typing "reb<cr>" reboots the laptop without pressing F12); or gives me an NMI either in picasso (in vesa add-on) or in net_server.

comment:9 by Adek336, 11 years ago

To boot, I have to type continue in the kdl prompt after a NMI.

comment:10 by mmlr, 11 years ago

The NMI is most probably not related to USB. The hang at boot might be though. Can you please enable on-screen debug output and check what the last few messages are that get printed when it hangs?

by Adek336, 11 years ago

Attachment: img-1.jpg added

by Adek336, 11 years ago

Attachment: syslog added

corresponding part of the syslog when boot succeeds

comment:11 by Adek336, 11 years ago

I obviously didn't see which boot icon appeared at that moment but I suspect this is what I was supposed to reproduce. Note that this problem happens occasionally, generally it happens only once in many boots. F12 didn't work. When on screen debug is enabled, at the beginning of the boot process, after only a few messages, I always get an NMI in main2(), but continue can be used to ignore it.

ints output under a successfully booted Haiku

...
int 11, enabled 3, handled 17912, unhandled 0
     firewire:fwohci_intr ...
     3com:intr_wrapper ...
     uhci: InterruptHandler_4UHCPIPv ...
...

comment:12 by Adek336, 11 years ago

On my desktop computer I've also seen Haiku freeze after the third icon, although very rarely, only a few times.

comment:13 by Adek336, 11 years ago

So this problem seems to occur to two rather different hardware settings. I think it is possible, that this bug happens to much more users, but they just ignore the problem and restart the computer after a freeze during boot.

I suggest adding the following to trunk

src/system/kernel/int.c:
221   -               dprintf("More than 99%% interrupts of vector %d are unhandled\n",
221   +               panic("More than 99%% interrupts of vector %d are unhandled\n",

so we could verify if it happens only for a handful, or for a vast group of users.

Also, it would give us more debugging options than now, when it freezes hard.

And I suspect that when the "More than" message appears, the system crawls and pretty much doesn't work anyway, so panicing it shouldn't harm anyone.

by Adek336, 11 years ago

Attachment: img_1044-mod.jpg added

More than 99%: backtrace

by Adek336, 11 years ago

Attachment: img_1045-mod.jpg added

More than 99%: teams, threads

comment:14 by Adek336, 11 years ago

Can't continue through the panic, though. It should panic() only the first time it finds out that more than 99% interrupts are unhandled, and later on only dprintf the message instead of panicing over and over.

comment:15 by scottmc, 7 years ago

Is this issue still with us? Do you still have the D810?

comment:16 by tqh, 5 years ago

Resolution: invalid
Status: in-progressclosed

No feedback in 21 months, closing.

Note: See TracTickets for help on using tickets.