Opened 5 years ago

Closed 10 months ago

#11491 closed bug (fixed)

[mail] can no longer send mail from yahoo account via smtp

Reported by: taos Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Applications/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm on hrev48340 gcc2hybrid.

It seems that I can no longer send emails from my yahoo account via smtp protocol in haiku. I get an error message that authentication failed:

error message

It used to work about one year ago with haiku alpha 4. However, it is not a regression in haiku since I can also no longer send mails from my alpha 4 installation. It seems that yahoo changed something in their authentication procedure. The strange thing is that I can still send from other mail applications in other operating systems without changing account settings. My outgoing settings in mail preferences:

settings in mail preferences

Attachments (2)

mail_preferences.png (29.8 KB ) - added by taos 5 years ago.
settings in mail preferences
mail_error.png (15.1 KB ) - added by taos 5 years ago.
error message

Download all attachments as: .zip

Change History (9)

by taos, 5 years ago

Attachment: mail_preferences.png added

settings in mail preferences

by taos, 5 years ago

Attachment: mail_error.png added

error message

comment:1 by czeidler, 5 years ago

Owner: changed from czeidler to axeld
Status: newassigned

comment:2 by richienyhus, 5 years ago

You do not happen to have Yahoo's 2 factor verification enabled do you?

That would mean you would need to generate an unique app password for Mail to work.

in reply to:  2 comment:3 by taos, 5 years ago

Replying to richienyhus:

You do not happen to have Yahoo's 2 factor verification enabled do you?

No, it's not enabled. I've never explicitly enabled it, and I just had a look at the settings a few minutes ago to make sure that it wasn't automatically enabled by yahoo either.

comment:4 by vercu, 5 years ago

I can confirm this problem. Receiving mails works. Sending mails with my yahoo pop mail account is not possible. Have tried different settings without success. This mail account did work in the past with Haiku.

comment:5 by vercu, 4 years ago

I noticed a problem when testing my yahoo.de mail account (it still does not work) on hrev49872: Haiku fills in the servers with the ending .de. Yahoo has changed this to .com also for the german accounts.

The current servers for a german pop mail account are (I have tested them successfully in Beam):

Eingehender E-Mail (POP) Server - Benötigt SSL

Server: pop.mail.yahoo.com Port: 995 Benötigt SSL: Ja Ausgehender E-Mail (SMTP) Server - Benötigt TLS

Server: smtp.mail.yahoo.com Port: 465 oder 587 Benötigt SSL: Ja Erfordert Authentifizierung: Ja Wenn Ihr POP-Client kein TLS anbietet, können Sie dennoch SSL verwenden.

comment:6 by vidrep, 3 years ago

hrev50675 x86_gcc2 This is still an issue with the current Haiku builds. I am able to receive emails from my Yahoo account, but cannot send due to failure to authenticate.

comment:7 by waddlesplash, 10 months ago

Resolution: fixed
Status: assignedclosed

ESMTP was broken; it was fixed in hrev52498.

Note: See TracTickets for help on using tickets.