Opened 12 years ago

Closed 12 years ago

#1154 closed bug (fixed)

Menu Pref -- Always Show Triggers non-functional (easy)

Reported by: mmadia Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

build 20674 on real hardware

The triggers -- underlined letters in menus are always activated. The Menu Pref app defaults to the setting not being enabled.

Attachments (1)

20070816 - Ticket 1154.diff (488 bytes) - added by anxiety 12 years ago.
Diff file

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by mmadia

Summary: Menu Pref -- Always Show Triggers non-functionalMenu Pref -- Settings are non-functional

comment:2 Changed 12 years ago by mmadia

should have played more before submitting the bug....

The Font, Font Size, and Color Scheme settings also have no effect on Tracker's menus. I have tried applying settings, quitting and restarting tracker through Process Controller -> Quit an App -> Tracker to no avail.

The Settings seem local to the Menu Pref program itself.

However. the choice between CTRL / ALT as Shortcut Key works. ( switching it results in on-the-fly changes )

comment:3 Changed 12 years ago by mmadia

possible regression of http://dev.haiku-os.org/ticket/521 ?

comment:4 in reply to:  2 ; Changed 12 years ago by jackburton

Replying to mmadia:

should have played more before submitting the bug....

The Font, Font Size, and Color Scheme settings also have no effect on Tracker's menus. I have tried applying settings, quitting and restarting tracker through Process Controller -> Quit an App -> Tracker to no avail.

The Settings seem local to the Menu Pref program itself.

Are you sure you are using a current build ? Because the menu font size is the first thing I change every time I start haiku, and I can assure you it works correctly since many revisions. To see the change in Tracker & Deskbar you need to restart them, though.

comment:5 in reply to:  4 Changed 12 years ago by mmadia

Replying to jackburton:

Replying to mmadia:

should have played more before submitting the bug....

The Font, Font Size, and Color Scheme settings also have no effect on Tracker's menus. I have tried applying settings, quitting and restarting tracker through Process Controller -> Quit an App -> Tracker to no avail.

The Settings seem local to the Menu Pref program itself.

Are you sure you are using a current build ? Because the menu font size is the first thing I change every time I start haiku, and I can assure you it works correctly since many revisions. To see the change in Tracker & Deskbar you need to restart them, though.

yeah, the build number is correct. somehow i was mistaken in my first reply -- it works as expected. (oops)

but the initial report of the "Always Show Triggers" not working as expected remains.

comment:6 Changed 12 years ago by jackburton

Description: modified (diff)
Summary: Menu Pref -- Settings are non-functionalMenu Pref -- Always Show Triggers non-functional

comment:7 Changed 12 years ago by wkornewald

Summary: Menu Pref -- Always Show Triggers non-functionalMenu Pref -- Always Show Triggers non-functional (easy)

comment:8 Changed 12 years ago by jackburton

Component: - GeneralKits/Interface Kit

comment:9 Changed 12 years ago by anxiety

I've been looking into this... and I think I have fixed the basic issue. The menu's local cached version wasn't getting set to the system setting when it was initialized.

I noticed another problem though... changing the setting in the Menu pref app does not immediately change all menus in the system but the change will show on any new menus that are created. This is the same for all menu settings, not just "Always Show Triggers." It would seem that there should be some better way of caching the value (which is needed for when custom data is sent) or some sort of global broadcast message alerting each menu that it needs to reevaluate the system settings if it isn't using custom settings. I don't know enough about the system to have any opinion on that.

Changed 12 years ago by anxiety

Attachment: 20070816 - Ticket 1154.diff added

Diff file

comment:10 Changed 12 years ago by anxiety

Just loaded up a copy of R5... it doesn't seem to change all menus instantly either, so I guess its a non-issue.

comment:11 Changed 12 years ago by leavengood

Resolution: fixed
Status: newclosed

Patch committed in hrev22011. I consider this bug solved. Thanks Justin.

Note: See TracTickets for help on using tickets.