Opened 4 years ago

Closed 4 months ago

#11565 closed bug (fixed)

[Network] preflet doesn't save DNS settings

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Network Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev48435.

Network preflet doesn't seem to save DNS settings.

Change History (8)

comment:1 Changed 4 years ago by bruno

I may have the same problem #11539

see also #9863 and #11209

At the moment I will be happy if the settings could be saved (after rebboot)... Automatic refresh will be sure great to have in the future... Until then I am happy with manual refresh...

comment:2 Changed 4 years ago by waddlesplash

Owner: changed from pulkomandy to axeld
Status: newassigned

Axel is currently working on a rewrite of the network preflet, so reassigning this to him.

comment:3 Changed 4 years ago by waddlesplash

Still an issue after the network preflet rewrite by Axel.

comment:4 Changed 4 years ago by bruno

For me... I am happy with it as is! Works for me so far!

comment:5 Changed 4 years ago by diver

Resolution: fixed
Status: assignedclosed

Seems to work now. Closing.

comment:6 Changed 4 years ago by axeld

Milestone: R1/beta1R1
Resolution: fixed
Status: closedreopened

I didn't make any changes in this regard. When you use DHCP, the net_server will overwrite your settings again; this whole thing is a bit messy right now, and will need a bit more love to be really usable.

comment:7 Changed 4 months ago by stippi

Should be fixed now with hrev52827. When saving the automatic settings, there are now "marker strings" in the host file which mark static and dynamic settings. And only the dynamic ones are rewritten.

comment:8 Changed 4 months ago by stippi

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.