Opened 5 years ago

Closed 14 months ago

Last modified 12 months ago

#11568 closed bug (fixed)

fails to boot up due to wireless drivers issue

Reported by: rishabhrawat Owned by: korli
Priority: high Milestone: R1
Component: Drivers/Network/iprowifi4965 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

The system enters KDL on booting up, the screenshot is attached,

However if we blacklist the iprowifi4965 drivers before booting up the system boots up properly, This issue is haiku nightly builds, but not present in r1alpha4.1 (but is suspect that is because drivers are not present)

KDL screenshot

Attachments (6)

IMAG1585.jpg (1.8 MB) - added by rishabhrawat 5 years ago.
KDL screenshot
2014-12-06 14.11.47.jpg (1.9 MB) - added by rishabhrawat 5 years ago.
2014-12-06 14.11.47.2.jpg (1.9 MB) - added by rishabhrawat 5 years ago.
syslog part where is detects my wireless hardware
panic message .jpg (1.9 MB) - added by rishabhrawat 5 years ago.
syslog end message.jpg (1.7 MB) - added by rishabhrawat 5 years ago.
r49058-KDL-System76_GazellePro.jpg (3.3 MB) - added by danboid 4 years ago.
KDL booting 49058 (GCC2 hybrid x86) on a System76 Gazelle Pro w/ Centrino 2230

Change History (24)

Changed 5 years ago by rishabhrawat

Attachment: IMAG1585.jpg added

KDL screenshot

comment:1 Changed 5 years ago by diver

As a workaround maybe you could try to use iprowifi4965 from r1alpha4.1 on current nightly? See driver changelog http://cgit.haiku-os.org/haiku/log/src/add-ons/kernel/drivers/network/wlan/iprowifi496.

Version 0, edited 5 years ago by diver (next)

comment:2 Changed 5 years ago by diver

Owner: changed from nobody to korli
Status: newassigned

comment:3 Changed 5 years ago by diver

Description: modified (diff)

comment:4 Changed 5 years ago by korli

A syslog while blacklisting would be nice. Also the panic message on top of the KDL picture is missing.

And finally, iwn_detach() is called because of a failure earlier in iwn_attach(). The actual failure message should be visible again at the end when you type "syslog". Please provide this message.

comment:5 Changed 5 years ago by diver

IIRC message reprints the message printed when entering KDL.

comment:6 in reply to:  5 Changed 5 years ago by korli

Replying to diver:

IIRC message reprints the message printed when entering KDL.

Yeah, but iwn should log a normal failure message like "can't find blah" or "can't allocate blah", which only is in the syslog.

Changed 5 years ago by rishabhrawat

Attachment: 2014-12-06 14.11.47.jpg added

Changed 5 years ago by rishabhrawat

Attachment: 2014-12-06 14.11.47.2.jpg added

syslog part where is detects my wireless hardware

Changed 5 years ago by rishabhrawat

Attachment: panic message .jpg added

Changed 5 years ago by rishabhrawat

Attachment: syslog end message.jpg added

comment:7 in reply to:  4 Changed 5 years ago by rishabhrawat

Replying to korli:

A syslog while blacklisting would be nice. Also the panic message on top of the KDL picture is missing.

And finally, iwn_detach() is called because of a failure earlier in iwn_attach(). The actual failure message should be visible again at the end when you type "syslog". Please provide this message.

i am attaching the relevant images, i.e the panic message, the syslog part where it detects my hardware and the end of syslog where it points out the problem

PS> sorry i uploaded a image twice and i don't know how to remove it

comment:8 Changed 5 years ago by luroh

Blocking: 7665 added

comment:9 Changed 4 years ago by danboid

I'm getting this same KDL on boot if I boot without safe mode enabled under 49058 on a System 76 Gazelle Pro laptop which uses a Centrino Wireless-N 2230.

I can sometimes get Haiku to boot with just safe mode & Use fail-safe video mode but most of the time I have to disable IO-APIC too to get it to boot successfully. I've not tried the most recent alpha release just yet.

If 2230 support hasn't already made it into Haiku, a backport of the FreeBSD 2230 driver to 9-STABLE is here:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196279

Changed 4 years ago by danboid

KDL booting 49058 (GCC2 hybrid x86) on a System76 Gazelle Pro w/ Centrino 2230

comment:10 Changed 4 years ago by danboid

I can boot alpha4.1 on my Gazelle Pro without any KDL nor having to use safe mode or disabling IO-APIC but unfortunately it doesn't support either of my network interfaces - Centrino 2230 and a RTL8111/8168/8411.

Maybe I can compile FBSD drivers for these under alpha4.1?

comment:11 Changed 4 years ago by danboid

After blacklisting iprowifi4965, I can boot 49058 provided I use fail-safe video mode. My Gazelle Pro has Intel HD4600 GFX.

comment:12 Changed 4 years ago by korli

I believe support for Centrino 2230 was added in hrev49127. Please test and provide a feedback.

comment:13 Changed 3 years ago by tojoko

negative, doesn't work

comment:14 Changed 14 months ago by waddlesplash

iprowifi4965 synced with FreeBSD in hrev52040. Please retest.

comment:15 Changed 14 months ago by waddlesplash

2200 confirmed to work in #12407, and the KDL was fixed in hrev52068. Closing as probably fully fixed; please open a new ticket if not.

comment:16 Changed 14 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

comment:17 Changed 13 months ago by waddlesplash

Blocking: 7665 removed

comment:18 Changed 12 months ago by tojoko

fix confirmed (for centrino wireless-n 2230 at least)

Note: See TracTickets for help on using tickets.