Opened 4 years ago

Closed 13 months ago

#12407 closed enhancement (fixed)

Intel Centrino Wireless-N 2200BGN

Reported by: DFergFLA Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/iprowifi4965 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Wireless card not being seen in Haiku.

hrev49663

vendor 8086: Intel Corporation
device 0891: Centrino Wireless-N 2200 (Centrino Wireless-N 2200 BGN)

Attachments (1)

syslog (508.3 KB) - added by DFergFLA 4 years ago.

Download all attachments as: .zip

Change History (20)

Changed 4 years ago by DFergFLA

Attachment: syslog added

comment:1 Changed 4 years ago by diver

Component: - GeneralDrivers/Network/iprowifi4965
Description: modified (diff)
Type: bugenhancement

Current iprowifi4965/iwn driver doesn't support your device id yet. It needs to be synced with FreeBSD http://fxr.watson.org/fxr/source/dev/iwn/if_iwn.c#L99

Last edited 4 years ago by diver (previous) (diff)

comment:2 Changed 4 years ago by DFergFLA

Thank you. Any idea on a timeline for that one?

Actually that was an unfair question. The better question would be. How will I know when I should try it again?

Last edited 4 years ago by DFergFLA (previous) (diff)

comment:3 Changed 4 years ago by diver

At the moment we use drivers from FreeBSD 9.3. No one can predict when someone has the time to do this work but this ticket will be closed once it's done and you'll get an email from Trac.

If you don't want to wait, take a look at the driver changelog. If you follow this link you see that the last commit added support for Intel Centrino Wireless-N 2230.

IIUC, this was backported from a newer driver specifically because someone didn't want to wait for the sync to be done. Maybe you could do the same thing?

comment:4 Changed 4 years ago by DFergFLA

I don't have the skill to do that. I will just have to wait.. and maybe beg.

comment:6 Changed 3 years ago by DFergFLA

Don't know. I downloaded build 50344 and Haiku will no longer boot on this hardware at all.

comment:7 Changed 3 years ago by tojoko

@DFergFLA more details please! have u tried blacklisting at least some drivers?

The problem might not (only) be Haiku related, since the source of the sourcecode is freebsd, iirc.

https://forums.freebsd.org/threads/53182/

comment:8 Changed 3 years ago by DFergFLA

Hi, sorry.

I was able to get Haiku to boot using a USB. This ticket, https://dev.haiku-os.org/ticket/12403, however is slowing me down. I can now boot, but I can't right or left mouse click. I am trying to find a USB mouse to use and when I do I will give this a try and report back.

comment:9 Changed 3 years ago by DFergFLA

I got the laptop running on USB. I go to terminal and type "install-wifi-firmware.sh" and hit enter. err: Command not found.

Sorry my bad, there is an "s" at the end for firmware I missed.

Last edited 3 years ago by DFergFLA (previous) (diff)

comment:10 Changed 3 years ago by DFergFLA

That said I ran the frimwares installer, accepted the licenses and rebooted. But still do not have wireless.

I know you guys hate to hear this stuff. But, it does work, "out of the box", in every Linux distro I have ever tried on this laptop.

comment:11 Changed 3 years ago by humdinger

Looks like our FreeBSD 9.3 iwi driver doesn't support your device ID, see if_iwi.c:

0x8086, 0x4220, "Intel(R) PRO/Wireless 2200BG"
0x8086, 0x4221, "Intel(R) PRO/Wireless 2225BG"
0x8086, 0x4223, "Intel(R) PRO/Wireless 2915ABG"
0x8086, 0x4224, "Intel(R) PRO/Wireless 2915ABG"

comment:12 Changed 3 years ago by DFergFLA

Well damn! I can always switch out the wireless card inside the Laptop. I've seen it, it's easy to get to. I would do that as soon as Issue 12403 is resolved. Can you recommend a card to put into the laptop?

comment:13 Changed 3 years ago by humdinger

Have a look at the HardwareInfo in the wiki. This is the chipset I use:

  vendor 8086: Intel Corporation
  device 088e: Centrino Advanced-N 6235

Uses the iprowifi4965 driver. It didn't want to connect to my router for a few months (though it did before!), now works like a charm again. Might be that one of the regular updates of my router's firmware broke it and another fixed it...

Also, I disable HT-mode, without it I keep losing connection.

comment:14 Changed 3 years ago by DFergFLA

I did some searching and I think this chipset is now supported by FreeBSD, so when someone gets around to syncing haiku drivers with FreeBSD I think it will work. :)

comment:15 Changed 13 months ago by waddlesplash

iprowifi4965 was synced with FreeBSD in hrev52041. Please retest.

comment:16 Changed 13 months ago by ttcoder

My T530 has a device that also lists as 8086 / 0891:

device Network controller [2|80|0]
  vendor 8086: Intel Corporation
  device 0891: Centrino Wireless-N 2200

In hrev52058 / x86_64 I do not get any wifi access listed...

The syslog mentions this:

KERN: [net/iprowifi4965/0] start running, 0 vaps running
KERN: [net/iprowifi4965/0] ieee80211_start_locked: up parent 
KERN: [iprowifi4965] (iwn) iwn_read_firmware: could not read firmware iwn2000fw
KERN: [iprowifi4965] (iwn) iwn_init_locked: could not read firmware, error -2147483643
KERN: [net/iprowifi4965/0] start running, 1 vaps running
KERN: [net/iprowifi4965/0] ieee80211_new_state_locked: INIT -> SCAN (nrunning 0 nscanning 0)
KERN: [net/iprowifi4965/0] ieee80211_newstate_cb: INIT -> SCAN arg 0
KERN: [net/iprowifi4965/0] sta_newstate: INIT -> SCAN (0)

Not sure if it's useful, but with a bit of digging I found #10197, which led me to https://git.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/network/wlan/iprowifi4965/glue.c .. which does not list an entry for firmware iwn2000fw indeed. Not sure if it's significant.

Thanks

comment:17 Changed 13 months ago by waddlesplash

It is indeed. Please retest after hrev52059.

comment:18 Changed 13 months ago by ttcoder

@waddlesplash thanks much, that did it. It works out of the box now, posting with it right now.

Don't know about the ticket OP, but as to me this ticket is done; most impressed with this hrev so far, including the DHCP negotiation which surprisingly took 2 seconds; had never seen that on any platform before (maybe I need to get out more *g*).

comment:19 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.