Opened 5 years ago

Closed 5 years ago

#11581 closed bug (fixed)

[HaikuDepot] doesn't display rating stars without VL-Gothic fonts

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11620
Has a Patch: no Platform: All

Description

Ever since VL-Gothic fonts were outsourced in hrev48457 HaikuDepot can't display rating stars in columnlistview if vl_gothic package is not installed. Featured packages view still display stars though (custom drawing?).

Attachments (1)

hrev48460_gcc2_nightly.png (179.9 KB ) - added by luroh 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by pulkomandy, 5 years ago

I should note that the VL-Gothic package is added to the release profile, making this not too critical for R1.

comment:2 by luroh, 5 years ago

Looks like I'm not seeing the same here, no VL-Gothic present but plenty of stars in HaikuDepot. Clean, from Linux cross-compiled hrev48460, gcc2, nightly-vmware profile. Attaching screenshot. Fwiw, I'm using the default locale.

Last edited 5 years ago by luroh (previous) (diff)

by luroh, 5 years ago

Attachment: hrev48460_gcc2_nightly.png added

comment:3 by diver, 5 years ago

Ok, this was because of droid fonts package. Without it stars are back. So I guess something is wrong with font overlay then?

Last edited 5 years ago by diver (previous) (diff)

comment:4 by axeld, 5 years ago

Yes, IIRC we still don't have any.

comment:5 by stippi, 5 years ago

No, actually we do have some font overlay support. But the font used for the overlay is hardcoded, IIRC.

Last edited 5 years ago by stippi (previous) (diff)

comment:6 by stippi, 5 years ago

Diver, when you had the droid installed, did you also use it as your system default font?

comment:7 by diver, 5 years ago

Yes, that what I've just tested. With DejaVu set as plain text the stars are there. With droid set as plain text there are no stars. VL-Gothic was not installed in both tests.

comment:8 by pulkomandy, 5 years ago

Ah, I didn't notice that. So here is probably what happens:

  • The stars are available in DejaVu, but not Droid
  • You didn't have VL-Gothic installed so there was no way to fallback to it (it is our only fallback font currently)

Root problem is the same anyway: we need a better font overlay that will look for missing symbols in more fonts, until it finds one that works.

comment:9 by stippi, 5 years ago

It appears that the Haiku base package should declare a dependency to VL-Gothic, since that is actually the situation. The app_server hard-codes VL-Gothic in the fall-back, so it "depends" on it. There is no question that the font overlay mechanism could be a lot better, however, declaring the dependency is a) correct and b) fixes the problem at hand.

comment:10 by anevilyak, 5 years ago

Blocking: 11620 added

(In #11620) Duplicate of #11581.

comment:11 by Giova84, 5 years ago

Sorry for the dup. As I've reported on my ticket, I've also found this issue with Terminal. I can confirm that installing the VL Gothic font has solved the issue, although I use different fonts for displaying.

comment:12 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

I added vl_gothic as a dependency of the Haiku package in hrev48505. Closing this since font overlay problems are already tracked in #7961.

Note: See TracTickets for help on using tickets.