Opened 4 years ago

Closed 2 months ago

#11607 closed bug (fixed)

wifi joins but can't DHCP

Reported by: donn Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/ralinkwifi Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11608
Has a Patch: no Platform: All

Description

Wifi configuration appears to semi-successfully negotiate with router, but then can't get DHCP addresses. Manual addresses don't help (static in Network Preferences, or manually via "route add"), so I suppose the problem is deeper, but DHCP is the first thing that clearly fails.

Platform is ASUS Eee PC 1000HE --- device Network controller [2|80|0]

vendor 1814: Ralink corp. device 0781: RT2790 Wireless 802.11n 1T/2R PCIe

Router is Buffalo Airstation Turbo G High Power. I notice that conversation ends with something about media change involving speed. Network Preferences shows speed at 100 Mb/s. Can't see what the MacOS X hosts set their speed to, with this router.

Attachments (2)

wlogr (10.6 KB) - added by donn 4 years ago.
syslog
syslog (337.0 KB) - added by -Meanwhile- 11 months ago.
Syslog for EeePC 901

Download all attachments as: .zip

Change History (18)

Changed 4 years ago by donn

Attachment: wlogr added

syslog

comment:1 Changed 4 years ago by korli

Blocking: 11608 added

comment:2 Changed 4 years ago by pulkomandy

Media speed in the network preferences always shows 100 Mb/s for everything, the feature isn't implemented and this is just a placeholder string.

comment:3 Changed 4 years ago by donn

I took the laptop out to a place within range of several open networks, and I think confirmed my suspicion that it doesn't really have much to do with DHCP. Sometimes it timed out in DHCP like this, others it went straight through that and got reasonable addresses, other times it got stuck in a loop of asking for a password (with the dialogue box indicating "Open".) In no case did it ever produce a usable network connection.

comment:4 Changed 4 years ago by gchauvet

Same issue with my ASUS EEE-PC 1001HA. My DHCP syslog output is identical to the reporter.

comment:5 Changed 4 years ago by waddlesplash

Dup of #12208?

comment:6 Changed 4 years ago by donn

It's hard to check anything, since I replaced the offending RT2790 card, but I'd say no. For one thing, I tried manual static addresses, no joy. For another, in some cases DHCP appeared to work. See comment 3.

comment:7 Changed 4 years ago by diver

Might be fixed in hrev49477.

comment:8 Changed 11 months ago by -Meanwhile-

I have an Asus EeePC 901 with the same Ralink that can't join any wireless network. It shows 'Symbol Not Found' for WPA2 and gets stuck 'configuring' for open networks. Tested on hrev52040.

comment:9 Changed 11 months ago by diver

'Symbol Not Found' message is odd. Does it say which symbol it is? Can reproduce this error message and look in syslog file for anything relevant?

Changed 11 months ago by -Meanwhile-

Attachment: syslog added

Syslog for EeePC 901

comment:10 Changed 11 months ago by -Meanwhile-

It doesn't say which symbol. I hope there's something relevant in the syslog (I wouldn't know...).

Last edited 11 months ago by -Meanwhile- (previous) (diff)

comment:11 Changed 11 months ago by diver

Like I expected you have an old binary in /boot/common/bin/

Last edited 11 months ago by diver (previous) (diff)

comment:12 Changed 11 months ago by -Meanwhile-

What can be done? Haiku on this machine is too problematic, I wiped the HD clean and put an older hrev50162 on it but to no avail, and the more recent hrev52039 can't be tested because it gives a KDL after the fourth icon lights up (it can't find any boot partitions). Update: sorry for hijacking this ticket; it seems my problem is related to https://dev.haiku-os.org/ticket/11013

Last edited 11 months ago by -Meanwhile- (previous) (diff)

comment:13 Changed 11 months ago by diver

I wiped the HD clean and put an older hrev50162 on it but to no avail

What do you mean? Did the 'Symbol Not Found' message go away on hrev50162 after you wiped your HD? You're not supposed to have /boot/common anyway.

comment:14 Changed 11 months ago by -Meanwhile-

I meant 'to no avail' in the sense that hrev50162 also didn't give me working wifi, but the 'symbol not found' alert is now gone. The symptoms with this revision are pretty much as explained in the comments of ticket #11013. And boot/common is also gone now.

Last edited 11 months ago by -Meanwhile- (previous) (diff)

comment:15 Changed 4 months ago by waddlesplash

Please retest under a recent nightly.

comment:16 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: newclosed

No reply in 2 months, and probably fixed after WiFi changes or hrev53000.

Note: See TracTickets for help on using tickets.