Opened 3 years ago

Last modified 7 months ago

#11636 reopened enhancement

Create Light and Dark themes

Reported by: jscipione Owned by: nobody
Priority: normal Milestone: R2
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #4868 Blocking:
Has a Patch: no Platform: All

Description

Haiku should have a light and dark theme. The light theme would come from the current Haiku theme while the dark theme invert the colors so all windows have a dark appearance and all text a light appearance. All apps will need to be updated to use new controls that respect both light and dark themes. BeOS apps will most likely work only using the light theme.

Attachments (1)

Haiku Dark Theme.png (125.6 KB) - added by jscipione 7 months ago.
Haiku Dark Theme

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 years ago by jscipione

  • Type changed from bug to enhancement

comment:2 Changed 3 years ago by cb88

Are there any specifics about why older apps would not work? I don't see why not unless they do things to override the default color scheme.

This might be an R2 thing seeing as BeOS didn't have it. And it would likely require some very thorough forethought on the part of the developers (non of the Linux toolkits I am aware of have a dark theme that doesn't have an issue here or there with readability/visibility)

comment:3 Changed 3 years ago by jscipione

BeOS apps might work, but mostly will have hard-coded colors which is why I wouldn't think they could be made to work unmodified. This is a big reason that this has to wait for R2.

comment:4 Changed 3 years ago by anevilyak

Any correctly written BeOS app should be using ui_color(), and as such should be able to adapt without much trouble, but there definitely are quite a few that didn't do that, and hardcoded instead.

comment:5 Changed 2 years ago by Janus

  • Blocked By 4868 added
  • Resolution set to duplicate
  • Status changed from new to closed

Dup of #4868.

comment:6 follow-up: Changed 2 years ago by richienyhus

This isn't a duplicate of #4868, but rather #4868 is a blocker of this ticket.

What is called a "Dark theme" here is a accessibility feature found in some other operating systems for people who have difficulty seeing dark text on light backgrounds.

comment:7 in reply to: ↑ 6 Changed 2 years ago by Janus

Replying to richienyhus:

This isn't a duplicate of #4868, but rather #4868 is a blocker of this ticket.

What is called a "Dark theme" here is a accessibility feature found in some other operating systems for people who have difficulty seeing dark text on light backgrounds.

I know with HaikuThemeManager you already have dark themes.

from #4868 "The result now is that dark themes with bright text is impossible to get right in Haiku."

comment:8 Changed 2 years ago by Janus

Usually is "inverted colors" a accessibility feature.

comment:9 Changed 7 months ago by jscipione

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This is a different feature than #4868 not meant for accessibility just looks

Changed 7 months ago by jscipione

Haiku Dark Theme

Note: See TracTickets for help on using tickets.