Opened 5 years ago

Closed 5 years ago

#11645 closed bug (duplicate)

[app_server] Xrs triggers debugger call - PicturePlayer::Play: buffer overrun

Reported by: Giova84 Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #10922 Blocking:
Has a Patch: no Platform: x86

Description

Well, some month ago I was still able to run Xrs [1] on Haiku, but since some week, if I attempt to run Xrs on Haiku, when I launch the app, this will just cause a KDL. Screenshots of that KDL attached.

[1] http://haikuware.com/directory/view-details/multimedia/audio/miscellaneous/xrs

Attachments (3)

KDL1.jpg (942.6 KB ) - added by Giova84 5 years ago.
KDL2_BT.jpg (681.9 KB ) - added by Giova84 5 years ago.
app_server-602-debug-19-12-2014-14-07-35.report (44.0 KB ) - added by Giova84 5 years ago.

Download all attachments as: .zip

Change History (8)

by Giova84, 5 years ago

Attachment: KDL1.jpg added

by Giova84, 5 years ago

Attachment: KDL2_BT.jpg added

comment:1 by anevilyak, 5 years ago

Component: ApplicationsServers/app_server
Owner: changed from nobody to axeld

That's actually an app_server crash, not a KDL. If you can reproduce it, please type save-report at the prompt, which should save a crash report that you can upload after rebooting.

comment:2 by Giova84, 5 years ago

Report attached

comment:3 by anevilyak, 5 years ago

Owner: changed from axeld to stippi
Status: newassigned

Looks like a problem in either BPicture or ServerPicture, stippi might have a better idea there.

comment:4 by anevilyak, 5 years ago

Summary: [Old app issue]: Xrs cause a KDL[app_server] Xrs triggers debugger call - PicturePlayer::Play: buffer overrun

comment:5 by anevilyak, 5 years ago

Blocked By: 10922 added
Resolution: duplicate
Status: assignedclosed

Looks like this is in fact a duplicate of #10922.

Note: See TracTickets for help on using tickets.