Opened 5 years ago

Closed 12 months ago

#11654 closed task (fixed)

Create update repositories for the beta release

Reported by: vidrep Owned by: mmlr
Priority: blocker Milestone: R1/beta1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: #12278 Blocking:
Has a Patch: no Platform: All

Description

On the Haiku Project page, under articles "Updating your system" it says:

"To update your system to packages in the repositories above..."

However, the "repositories above" which previously showed the path(s) to the various builds are now missing from the page, and the path(s) in the default repo list do not point the pkgman update command to the correct path(s).

Attachments (1)

screenshot1.png (116.9 KB ) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (10)

by vidrep, 5 years ago

Attachment: screenshot1.png added

comment:1 by vidrep, 5 years ago

The default url(s) for a fresh install of Haiku hrev48530 is as follows:

Haiku base-url: http://packages.haiku-os.org/haiku/master/x86_gcc2/r1~alpha4_pm_hrev48530

HaikuPorts base-url: http://packages.haiku-os.org/haikuports/master/repo/x86_gcc2/62b2370269331a590c3b9b35fe77501460fab92dd09c7c196bd0ede12f580b45

Why isn't the package manager update url(s) pointing to the current directories, so that we no longer need to find and enter them manually later?

Haiku base-url: http://download.haiku-os.org/haiku-repositories/master/x86_gcc2/current/ HaikuPorts base-url: http://packages.haiku-os.org/haikuports/master/repo/x86_gcc2/current

Last edited 5 years ago by vidrep (previous) (diff)

comment:2 by waddlesplash, 5 years ago

Component: Applications/HaikuDepotBuild System
Milestone: R1Unscheduled
Owner: changed from stippi to bonefish
Priority: normallow
Type: bugenhancement

Having the update URLs point to the current directories would be nice, I agree. I can't recall if Ingo & Oliver had any reason against it other than "automatic updating isn't implemented" (which is now not true).

Changing the package repos' definitions in the build system is easy, but we need an OK from Oliver or Ingo before doing so.

comment:4 by pulkomandy, 5 years ago

Milestone: UnscheduledR1/beta1
Priority: lownormal
Type: enhancementtask

The reason for not having "current" used in the nightlies is that we don't want them to auto-update. It is important that nightlies provide a fixed set of packages for a given hrev for testing of regressions (so you can say running hrevxxxx, package y works/does not work).

For the beta release there will be a specific URL setup (not "current") where you will get updates from the beta branch of Haiku, and packages that have been tested compatible with the release.

The URLs in the article look correct (packages.haiku-os.org redirects to download.haiku-os.org).

I'm keeping the ticket open as a task so we don't forget to set this up for the beta release, but there will be no fix for the nightlies.

comment:5 by waddlesplash, 4 years ago

Summary: Update repositories missingCreate update repositories for the beta release

comment:6 by pulkomandy, 4 years ago

Blocked By: 12278 added

(In #12278) Except there is already a ticket for that :)

comment:7 by pulkomandy, 4 years ago

Priority: normalblocker

comment:8 by pulkomandy, 2 years ago

Owner: changed from bonefish to mmlr
Status: newassigned

comment:9 by waddlesplash, 12 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.