Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11746 closed bug (fixed)

regression: hrev48667 only boots with "Disable ACPI"

Reported by: taos Owned by: anevilyak
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I've updated from hrev48662 gcc2hybrid to hrev48667. Booting now stops at the forth boot splash icon (last page of on-screen debug output is attached). I can then enter KDL with Alt +SysReq +d (bt output attached). After disabling ACPI in haiku safe mode options hrev48667/hrev49668 boots to the desktop. Unfortunately, the system is not usable since CPU consumption stays at 100%. Syslog with successful and unsuccessful boot attempts of hrev48662, hrev48667, and hrev48668 is attached.

Attachments (4)

syslog.old.txt (512.0 KB) - added by taos 4 years ago.
syslog.txt (249.2 KB) - added by taos 4 years ago.
bt.jpg (183.3 KB) - added by taos 4 years ago.
KDL - bt ouput
onscreen_debug.jpg (140.6 KB) - added by taos 4 years ago.
onscreen debug output

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 years ago by anevilyak

Component: - GeneralSystem/Kernel
Owner: changed from nobody to pulkomandy
Status: newassigned

Changed 4 years ago by taos

Attachment: syslog.old.txt added

Changed 4 years ago by taos

Attachment: syslog.txt added

Changed 4 years ago by taos

Attachment: bt.jpg added

KDL - bt ouput

Changed 4 years ago by taos

Attachment: onscreen_debug.jpg added

onscreen debug output

comment:2 Changed 4 years ago by anevilyak

Owner: changed from pulkomandy to anevilyak
Status: assignedin-progress

I'm able to reproduce a similar issue over here, and it appears to be in the code that handles the module image table. Looking into it...

Last edited 4 years ago by anevilyak (previous) (diff)

comment:3 Changed 4 years ago by anevilyak

Resolution: fixed
Status: in-progressclosed

Fixed in hrev48669.

comment:4 Changed 4 years ago by taos

Sorry, that I couldn't check sooner: Works for me, too. Thanks!

Note: See TracTickets for help on using tickets.