Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11754 closed bug (duplicate)

Package manager update tries to downgrade to previous revision

Reported by: vidrep Owned by: bonefish
Priority: normal Milestone: R1
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: #10835 Blocking:
Has a Patch: no Platform: All

Description

Installed latest nightly hrev48679 x86_gcc2 Added current repositories Run "pkgman full-sync" command in terminal Package manager offers to install previous revision (hrev48678) See screenshot1 (attached)

Attachments (1)

screenshot1.png (181.1 KB) - added by vidrep 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by vidrep

Attachment: screenshot1.png added

comment:1 Changed 4 years ago by vidrep

Normally, package manager would say "nothing to do".

comment:2 Changed 4 years ago by anevilyak

Component: Applications/PackageInstallerKits/Package Kit
Owner: changed from sil2100 to bonefish

For future reference, PackageInstaller is the one that handles old BeOS .pkg files.

comment:3 Changed 4 years ago by waddlesplash

Intended behavior (as the package repositories currently contain hrev48678, and full-sync will downgrade/remove packages). Duplicate of #10835.

comment:4 Changed 4 years ago by anevilyak

Blocked By: 10835 added
Resolution: duplicate
Status: newclosed

comment:5 Changed 4 years ago by vidrep

I also tried with 64 bit build and did not experience this behavior.

comment:6 Changed 4 years ago by waddlesplash

Note: See TracTickets for help on using tickets.