Opened 12 years ago

Closed 12 years ago

#1183 closed bug (fixed)

unexpected reboot when opening a bookmark file with urlwrapper

Reported by: mmu_man Owned by: axeld
Priority: critical Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When trying something korli suggested with urlwrapper:

touch /boot/home/Desktop/Download\ Mozilla\ Firefox
addattr -t mime "BEOS:PREF_APP" "application/x-vnd.Haiku-urlwrapper" /boot/home/Desktop/Download\ Mozilla\ Firefox
addattr -t mime "BEOS:TYPE" "application/x-vnd.Be-bookmark" /boot/home/Desktop/Download\ Mozilla\ Firefox
addattr "META:url" "http://bebits.com/bob/20795/firefox-2.0.0.3.en-US.beosBONE-i586.zip" /boot/home/Desktop/Download\ Mozilla\ Firefox

(one might have to run urlwrapper in Terminal once to get it mime sniffed)

When opening the bookmark file it just reboots without warning. Nothing in serial debug output.

Change History (3)

comment:1 by mmu_man, 12 years ago

doing an

open http://127.0.0.1

seems to start Terminal which quits immediately. After several tries one gets a reboot as well, seems like a resource leak or something alike.

comment:2 by mmu_man, 12 years ago

Oddly I can't seem to reproduce it with hrev20854, maybe it got fixed, or my build was broken... Will need more testing.

comment:3 by axeld, 12 years ago

Resolution: fixed
Status: newclosed

There were many bugs that could have caused this, but at least it seems to be pretty stable right now - I'm closing that bug for now :-) As a reference I mention hrev21672 once that should have finally fixed it.

Note: See TracTickets for help on using tickets.