Opened 4 years ago

Closed 4 years ago

#11855 closed bug (fixed)

LoggingConsumer crashes media_addon_server

Reported by: codewrangler Owned by: waddlesplash
Priority: normal Milestone: R1
Component: Applications/Cortex Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am using nightly build hrev48800 and have OpenSound installed.

Steps to reproduce:

  1. Update Haiku OS to hrev48800 with OpenSound driver
  2. Reboot Haiku OS
  3. Notice that 'media_addon_server' crashes
  4. Notice that there is no longer sound (no mixers)

Attachments (2)

mas_crash.png (25.9 KB) - added by codewrangler 4 years ago.
Screenshot of Crash Dialog
media_addon_server-703-debug-13-02-2015-18-48-23.report (11.8 KB) - added by codewrangler 4 years ago.
Crash log file

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by codewrangler

Attachment: mas_crash.png added

Screenshot of Crash Dialog

Changed 4 years ago by codewrangler

Crash log file

comment:1 Changed 4 years ago by waddlesplash

Component: - GeneralApplications/Cortex
Owner: changed from nobody to waddlesplash
Status: newassigned
Summary: media_addon_server crashes on startupLoggingConsumer crashes media_addon_server

Oops. Looks like there's something wrong with LoggingConsumer. Investigating...

comment:2 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev48801.

Note: See TracTickets for help on using tickets.