Opened 4 years ago

Closed 12 months ago

#11860 closed bug (fixed)

Giddy3 game crashes due to SDL error

Reported by: dsuden Owned by: kallisti5
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/Development
Keywords: Cc:
Blocked By: #6400 Blocking: #11984
Has a Patch: no Platform: All

Description

Feel free to give this bug the heave-ho if it's not directly Haiku-related! I get a crash of Giddy3 on launch, which results in the attached debug info.

Attachments (3)

giddy3-6385-debug-16-02-2015-16-15-38.report (16.4 KB) - added by dsuden 4 years ago.
mpv-8651-debug-08-01-2016-17-28-09.report (52.7 KB) - added by khallebal 3 years ago.
mpv-8681-debug-08-01-2016-17-28-42.report (50.7 KB) - added by khallebal 3 years ago.

Download all attachments as: .zip

Change History (15)

Changed 4 years ago by dsuden

comment:1 Changed 4 years ago by pulkomandy

Blocked By: 6400 added
Component: - GeneralKits/OpenGL Kit
Owner: changed from nobody to kallisti5

It's actually a problem with the use of BLocker in our mesa port, which uses a quirk that worked in BeOS and never worked in Haiku (previously it was ignored, now it's entering debugger, see #6400).

The crash is continuable: click the "debug" button, then quit debugger and click "resume". The app should then run (unless there are other bugs). Anything using SDL and OpenGL will hit this problem (some other games like f1spirit, for example).

comment:2 Changed 4 years ago by pulkomandy

Blocking: 11984 added

(In #11984) As analyzed in #6400 and #11860, this is a problem with the way OpenGL use BLockers. Before hrev48542 there was no debugger call, but the lockers were never unlocked in that situation. We need to review the locking in OpenGL and fix that.

comment:3 Changed 3 years ago by luroh

Seems fixed here (along with ##11984) in hrev49751, gcc2h.

comment:4 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Yes, mmlr adjusted BLocker behavior to match BeOS exactly, so SDL/BGLView works again.

comment:5 Changed 3 years ago by diver

For reference: fixed in hrev49751.

Changed 3 years ago by khallebal

Changed 3 years ago by khallebal

comment:6 Changed 3 years ago by diver

Should be filed as a separate ticket as it's not related.

comment:7 Changed 3 years ago by khallebal

Resolution: fixed
Status: closedreopened

comment:8 Changed 3 years ago by khallebal

@diver i got your reply before i finished editing this ticket.

From the following console message i got it seems related:

Unlocking BLocker with sem 111113 from wrong thread 8690, current holder 8692 (see issue #6400).

but i can open a new one if it's not the case.

comment:9 Changed 3 years ago by diver

Where did you get this message from?

comment:10 in reply to:  9 Changed 3 years ago by khallebal

Replying to diver:

Where did you get this message from?

What do you mean? this is the output mpv generated on the terminal when i launched it.

comment:11 Changed 12 months ago by cocobean

Tested on hrev51894 w/Giddy3. Game ran good for length of play (5m-10m). Couldn't duplicate crash issue upon launch.

comment:12 Changed 12 months ago by pulkomandy

Resolution: fixed
Status: reopenedclosed

Indeed this is fixed. Someone reopened the ticket when they should have filed a separate one.

Note: See TracTickets for help on using tickets.