Opened 4 years ago

Closed 4 years ago

#11984 closed bug (duplicate)

GLTeapot crashes on launch since 48542

Reported by: luroh Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/GLTeapot Version: R1/Development
Keywords: Cc:
Blocked By: #6400, #11860 Blocking:
Has a Patch: no Platform: All

Description

hrev49047, gcc2. Will look into finding a regression range tomorrow.

Attachments (1)

GLTeapot-475-debug-18-04-2015-18-58-14.report (10.7 KB) - added by luroh 4 years ago.
hrev49047, gcc2

Download all attachments as: .zip

Change History (4)

comment:1 Changed 4 years ago by luroh

Owner: changed from kallisti5 to pulkomandy
Status: newassigned
Summary: GLTeapot crashes on launchGLTeapot crashes on launch since 48542

It turned out to be an older problem than I somehow thought, hrev48542.

comment:2 Changed 4 years ago by luroh

Blocked By: 6400 added

comment:3 Changed 4 years ago by pulkomandy

Blocked By: 11860 added
Resolution: duplicate
Status: assignedclosed

As analyzed in #6400 and #11860, this is a problem with the way OpenGL use BLockers. Before hrev48542 there was no debugger call, but the lockers were never unlocked in that situation. We need to review the locking in OpenGL and fix that.

Note: See TracTickets for help on using tickets.