Opened 4 years ago

Closed 4 years ago

#11863 closed bug (invalid)

Pixelitor needs compatibility with HaikuDepot's OpenJDK

Reported by: dsuden Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Maybe this belongs over at HaikuPorts?

This is an impressive program: http://haikuware.com/directory/view-details/hpkgs/pixelitor-hpkg

It works great using a "special" version of OpenJDK available here: http://clasquin-johnson.co.za/michel/haikufiles/openjdk_x86-1.7_2014_05_28-x86_gcc2.hpkg

But it doesn't work with HaikuDepot's OpenJDK. Seems like a great app to bring into the HaikuDepot fold.

Change History (3)

comment:1 Changed 4 years ago by korli

Please define "it doesn't work". Which Haiku revision did you check on?

comment:2 Changed 4 years ago by pulkomandy

More complete report from IRC channel: pixelitor depends on "openjdk >= 1.7", and it seems our openjdk package doesn't provide that (probably it provides openjdk_x86 instead).

I think the "correct" fix is making pixelitor depend on cmd:java or something similar, so any Java implementation can be used? We need a recipe for it in any case, as the existing package was apparently manually built.

comment:3 Changed 4 years ago by waddlesplash

Resolution: invalid
Status: newclosed

Belongs over at HaikuPorts.

Note: See TracTickets for help on using tickets.