Opened 5 years ago

Last modified 4 years ago

#11900 assigned bug

[Haiku-64bit] WebPositive can't start due to missing sqlite library - sqlite hpkg present but can't be expanded

Reported by: taos Owned by: bonefish
Priority: normal Milestone: Unscheduled
Component: File Systems/packagefs Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The following problem only affects Haiku-64bit (tested on hrev48893): After the latest sqlite update, there is a sqlite package that - even though it is marked as active in HaikuDepot (or is downloaded repeatedly) can't show its contents. The same happens if you try to show its contents in Expander. Additionally, no corresponding sqlite library shows up under /system/libs. WebPositive is one of the applications affected by missing sqlite.

Attachments (1)

syslog (456.5 KB ) - added by diver 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by korli, 5 years ago

Owner: changed from nobody to korli
Status: newassigned

I'll have a look later today.

comment:2 by korli, 5 years ago

I tried the update today: it seems the old libs are still used, but not here anymore. After a reboot, WebPositive works as good as it used to. I don't know what would be wise to investigate yet.

comment:3 by taos, 5 years ago

I think this ticket can be closed. Several reboots didn't help, however, after a complete shutdown content of sqlite package was available again (different behaviour bare metal <-> VirtualBox?). Updating to a new version of nasm did not result in the same problem - after only one reboot everything worked as expected (content availabe in /system/bin, HaikuDepot, and Expander).

comment:4 by diver, 5 years ago

Component: - GeneralFile Systems/packagefs
Milestone: UnscheduledR1

I've just had a similar problem activating freshly built mpg123_x86_devel-1.22.0-1 package. While syslog showed nothing unusual the package itself wasn't mounted. Tried to delete it and install again about 10 times. Finally decided to reboot and that fixed it.

package_daemon [19935954978:  3622] Volume::_PackagesEntryCreated("mpg123_x86_devel-1.22.0-1-build.hpkg")
package_daemon [19935965446:  3622] CommitTransactionHandler::_ChangePackageActivation(): activating 1, deactivating 0 packages
packagefs [19935968737:  3622] Volume::_ChangeActivation(): 1 new packages, 0 old packages
packagefs [19935969349:  3622] package "mpg123_x86_devel-1.22.0-1-build.hpkg" activated

comment:5 by diver, 5 years ago

Owner: changed from korli to bonefish

by diver, 5 years ago

Attachment: syslog added

comment:6 by waddlesplash, 4 years ago

Milestone: R1Unscheduled
Note: See TracTickets for help on using tickets.