Opened 4 years ago

Closed 4 years ago

#11912 closed bug (no change required)

SMTP Fails to Authenticate

Reported by: BeDucky Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/mail_daemon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've been using an HREV47259 VM inside VMware on a Windows 7 (64-bit) laptop as my main e-mail machine (via BEAM) since late May of 2014. Starting March 6, 2015 sending mail refused to work with the message "535 5.7.8 Error: authentication failed:". POP still works fine with the same user/password combination. (Plain password, unencrypted)

This reminded me that I had installed HREV48786 inside VirtualBox on a different computer in mid-January, and it had this same problem right from the start. In this case it was a 32-bit version of Windows Vista acting as the host. (I filed it under "figure this out when I find time," and it never made it back up to the top of my To Do list.)

In my trouble shooting, I did a fresh install of HREV48871 on two more machines inside VirtualBox: one a Win7-64 machine, the other a Manjaro Linux host. They both refuse to send mail in their Haiku VMs with the same error. SMTP works on both these machines both in the host OSes and in Linux-based virtual machines.

I've played around with all the settings that might have anything to do with networking, with no success. I'm stumped.

Between the last successful e-mail send and when SMTP gave up, I don't think I made any changes in to the host OS or VMware on the machine that used to work but stopped. I believe I did change the account password in that time period, but the old password was the one that refused to work in the first place on the Vista machine, so that seems unlikely to be the culprit. Even if it was, say, the special characters in the password, I tested it out with a dictionary word + a single number password...no dice. Also, I'd tried sending on both port 25 and 587, so that's not it. And it doesn't seem like it's a problem with the mail server or mail account in question, because I tried it out with more than one account and mail server. Plus, why would it work for POP, but not SMTP? Sigh.

I took one stab at trying to use Mail to send, but it died silently--as Mail is wont to do--and I don't think I ever got it to work even last year when BEAM worked without porblems, so I don't know if this is specific to the application.

Change History (4)

comment:1 Changed 4 years ago by anevilyak

Component: - GeneralServers/mail_daemon
Owner: changed from nobody to axeld
Status: newassigned

comment:2 Changed 4 years ago by axeld

Beam is not part of Haiku, and Beam usually does not use Haiku's mail_daemon to send mails, although I believe you can configure it as such. Did you do that?

I'm afraid we'll need a lot more information on the actual problem in order to be able to do anything useful here. Most likely, your provider did change something, and Haiku does not cope with it.

Is it a free service provider? Could anyone register a mail account there? If so, please share that information, so that we can try this, too. If not, please launch Beam and/or the mail_daemon from a Terminal, and paste their output to this bug report.

comment:3 in reply to:  2 Changed 4 years ago by BeDucky

Sorry to take so long to get back to you, but I was away from the Internet for a couplefew days, and then too busy catching up on work to get back to this. But I'm on the case now.

Replying to axeld:

Beam is not part of Haiku, and Beam usually does not use Haiku's mail_daemon to send mails, although I believe you can configure it as such. Did you do that?

I didn't realize this was the case with Beam. I've searched around, but can't find anything that says how Beam can be configured to use Haiku's mail_daemon. I'll contact the author through Beam's SourceForge page, and cross my fingers that he's still around and answering questions.

It does seem as though that is the root cause, because after smacking Mail around with a wet trout for a little while, I got it to actually send some e-mail's, so it's unlikely to be a mail_daemon problem.

Is it a free service provider? Could anyone register a mail account there? If so, please share that information, so that we can try this, too.

I can set you up with a mail account on one of the servers if you still want to try that out...just so long as you promise not to use it to send threatening letters to heads of state or whatnot. Just give me a way to direct message you the pertinent details so that I'm not posting passwords for the world to see.

If not, please launch Beam and/or the mail_daemon from a Terminal, and paste their output to this bug report.

I suspect I'm doing this wrong... Launching Beam via Terminal, then attempting to send a mail and closing the application via GUI shows no output in the Terminal.

Launching mail_daemon via Terminal immediately output:

POP3Protocol::POP3Protocol(BMailAccountSettings* settings)
account name [USER]@[DOMAIN], id 1401982588, in 0x18189160, out 0x18157d40

The only further output I saw came from Mail application activity:

POP3Protocol::SyncMessages()

I saw no output from sending messages.

Let me know what else you need from me, if anything.

comment:4 Changed 4 years ago by zooey

Resolution: no change required
Status: assignedclosed

I have contacted the reporter by private mail, so I'm closing this as it is probably just an application bug.

Note: See TracTickets for help on using tickets.