Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11913 closed bug (invalid)

Thinkfree Office (all programs) crash upon start

Reported by: dac324 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Thinkfree Office Java JVM Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello all,

recently, I wanted to try Thinkfree Office (using the installer from Haikuware.ru.

But unfortunately, none of the apps (writer, calc, ...) could be started. They immediately crash. Attached is the debug log.

Kind regards.

P.S.: The component drop down menu does not seem to have an entry for Thinkfree Office, therefore I had to use General.

Attachments (1)

ThinkFree Office-10075-debug-18-03-2015-15-10-07.report (4.8 KB ) - added by dac324 5 years ago.
Thinkfree Office Debug Report for Write

Download all attachments as: .zip

Change History (9)

by dac324, 5 years ago

Thinkfree Office Debug Report for Write

comment:1 by anevilyak, 5 years ago

Resolution: invalid
Status: newclosed

This bug tracker is only for the OS itself, not third party apps. As such, a crash in thinkfree should first be reported to whoever maintains it. Only if it's determined that the crash in question is a result of a bug in the OS should a ticket be filed here.

comment:2 by dac324, 5 years ago

Please have a look at the debug report.

To me it looks like the app causes a segment violation in /boot/system/lib/x86/libnetwork.so . This does not exacltly look like a third-party program issue but rather to a system-related problem.

comment:3 by dac324, 5 years ago

Resolution: invalid
Status: closedreopened

comment:4 by dac324, 5 years ago

As for libnetwork.so, my guess was that the program perhaps tries to open a connection to the internet. As I am using a proxy, I will have to set the http_proxy environment variable first.

For testing, I therefore set the http_proxy variable in a terminal shell and then tried to start Thinkfree Write from the shell. Of course, the program did not work either but gave some additional info:

resolve symbol "_get_system_info" returned: -2147478780
Error: dl failure on line 881
Error: failed /Haiku Data/apps/ThinkFree Office 4.0/jre/lib/i386/client/libjvm.so, because Symbol not found

This also looks to me like some kind of system related problem.

comment:5 by modeenf, 5 years ago

I don't know if this has to do with the OS but more the Java engine.

I think that "Unable to retrieve disassembly for IP 0x586021: No such file or directory" are error for not getting the debug output and not the error for running the office.

also the app are 3 years old, perhaps it's built for alpha 4 so it need's to get rebuild :)

in reply to:  2 comment:6 by anevilyak, 5 years ago

Resolution: invalid
Status: reopenedclosed

Replying to dac324:

To me it looks like the app causes a segment violation in /boot/system/lib/x86/libnetwork.so . This does not exacltly look like a third-party program issue but rather to a system-related problem.

That's absolutely not the case. If a third party program passes an invalid buffer pointer to a system function, that system function will crash. This is equally true on any other OS you can name, and in no way implies that the OS itself is at fault. As I said, please take this up with the people maintaining the Thinkfree port for Haiku. If they can determine that it's not a problem on their end, and provide a reproducible test case, then all well and good, file a ticket here. I should also note, the JVM side of things is very much a work in progress as far as the Haiku port goes, so it's not entirely improbable that it could be a bug there too.

resolve symbol "_get_system_info" returned: -2147478780

As far as this is concerned, the programs in question are built with gcc4.x. We currently don't guarantee binary compatibility on that front, and won't until R1 is out the door. As such, if it was compiled against a random older nightly, it's entirely possible for things like this to occur, especially if gcc was upgraded to a newer revision in the meantime.

comment:7 by dac324, 5 years ago

Update: It has something to do with the JRE being used.

The installer from Haikuware.ru also installs an own version of the JRE which appears to be incompatible with recent versions of Haiku.

I renamed apps/ThinkFree Office 4.0/jre to jre-bak and instead created a symlink to the JRE included in the OpenJDK package.

With that symlink, at least Calc and Show can be started. Write as well as TF settings will not start but they also give no error. They simply do not start. Strace reveals that the Java engine is not able to find the program's main class. Perhaps, they hard-coded a path or something.

So I have to apologize for having gotten mislead by that libnetwork.so debug message - clearly is an application-related problem. Unfortunately, there seems to be no active maintainer for the Haiku "port" so I am on my own here.

Kind regards.

Note: See TracTickets for help on using tickets.