Opened 4 years ago

Closed 4 years ago

#11935 closed bug (fixed)

hda-problems playing sound mp3 with media addon server

Reported by: bruno Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Audio & Video Version: R1/Development
Keywords: hda Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have problems now to play audio files. If i restart the media preferences sometimes sound suddently works. Sometimes i have to kill the media addon server or the media player... Dont know how to describe my problem... What else is helpful for you to get this problem down?

Change History (17)

comment:1 by anevilyak, 4 years ago

From your description, this behavior started recently for you. Would you be able to narrow down a revision when it started?

comment:2 by SeanCollins, 4 years ago

I am having the same issue, started within the last week, I update my system weekly. Is there anyway to update a haiku install to a specific revision ? if so I can bisect this tonight

in reply to:  2 comment:3 by humdinger, 4 years ago

Replying to SeanCollins:

Is there anyway to update a haiku install to a specific revision ? if so I can bisect this tonight

If you've been updating Haiku regularly (instead of installing an image from scratch), you can enter the boot options (hold SHIFT while booting up) and choose the revision to boot from the menu. Should work if you didn't delete stuff from the packages/administration/ folder. Haven't done it myself yet, though.

comment:4 by bruno, 4 years ago

I just booted and choose an older version the way Humdinger described. It works! but my last update was on 27.January... so too old to narrow down the problem. After booting to that older version my files are playing normal again. Maybe SeanColins has an better revision to boot!?

comment:5 by Barrett, 4 years ago

Can you confirm that the second crash happen when MediaPlayer is started before a restart of media_server? Strange things happens, and i seem to recall crashes like yours in this situation.

Be careful with HDA Audio i always have to wait a little bit before to hear sound from speakers after a restart. Could you please also check what's the status before the following revisions? I doubt that they can be the cause...but who knows :-)

http://cgit.haiku-os.org/haiku/commit/?id=49f0011c1e19d0bdb731957e8847b6debf79e3cb

http://cgit.haiku-os.org/haiku/commit/?id=7f01171f92590974b7485b57a0d5ec0859d60b82

Also be aware of #5621 (which i solved in a WIP patchset).

comment:6 by diver, 4 years ago

The crashes are the same as in #6188.

comment:7 by SeanCollins, 4 years ago

revision 48968 crash report, no audio at all.

comment:8 by SeanCollins, 4 years ago

hrev 48927 is the last hrev I have on my machine with working audio, not many changes to really bisect.

comment:9 by SeanCollins, 4 years ago

http://cgit.haiku-os.org/haiku/commit/?id=2889e51c4e1e1b8647645de65fd06aada6e47db1

not sure if this commit is related, but now my audio is working again, no crash on bootup like I had been getting either

hrev 48981

comment:10 by bruno, 4 years ago

I still have this problem... After booting Haiku I tried to wait a bit... tried to open a .mp3 file... and the media addon server crashed! Attachement added... No.5 I did not have this problem with a late january build!

comment:11 by bruno, 4 years ago

Works now... dont` know why... but it is working again now! After reboot all my music files are playing now...

Thanks

If I get problems again I will file a bug report again! href: 49038

comment:12 by korli, 4 years ago

Resolution: fixed
Status: newclosed

#6188 was fixed, maybe this helps in your case.

Note: See TracTickets for help on using tickets.