Opened 5 years ago

Closed 17 months ago

Last modified 4 months ago

#11938 closed bug (duplicate)

Network Preferences: Disable/Enable Ethernet Device Not Working

Reported by: vidrep Owned by: phoudoin
Priority: normal Milestone:
Component: Preferences/Network Version: R1/Development
Keywords: Cc: phoudoin, tqh
Blocked By: #9695 Blocking: #12300
Platform: All

Description

In Network Preferences: Select Ethernet device Disable Ethernet device disabled Status: connected Enable Ethernet device connected Status: connected

Enable does not restore internet connection until after a reboot

hrev48971 x86_gcc2

Attachments (2)

screenshot1.png (121.1 KB ) - added by vidrep 5 years ago.
screenshot2.png (85.5 KB ) - added by vidrep 4 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by vidrep, 5 years ago

hrev49346 x86_gcc2 Gateway is not restored after disable/enable ethernet device (screenshot1).

Last edited 2 years ago by vidrep (previous) (diff)

by vidrep, 5 years ago

Attachment: screenshot1.png added

comment:2 by jackburton, 5 years ago

Disabling the interface does work here: IOW on disable, network goes down. It doesn't get up again on enabling, though.

comment:3 by vidrep, 4 years ago

I found that there is a sequence of steps that can be taken to re-enable the connection:

Network Preferences -> Disable Network Preferences -> Renegotiate Select IPv4 (Gateway field is blank - see attached screenshot2) Change Mode from DHCP to Disabled then back to DHCP again Network connection is established again

Last edited 4 years ago by vidrep (previous) (diff)

by vidrep, 4 years ago

Attachment: screenshot2.png added

comment:4 by vidrep, 4 years ago

Is there a log I can attach, or some step I can take here to help resolve the issue?

comment:5 by vidrep, 4 years ago

Tested with hrev50448 x86_gcc2 This is still an issue. This ticket can be batched together with ticket #12300.

comment:6 by phoudoin, 3 years ago

Cc: phoudoin added

comment:7 by vidrep, 3 years ago

Owner: changed from pulkomandy to phoudoin
Status: newassigned

comment:8 by vidrep, 2 years ago

Blocking: 12300 added

comment:9 by vidrep, 2 years ago

Owner: changed from phoudoin to tqh

comment:10 by vidrep, 2 years ago

Cc: tqh added
Owner: changed from tqh to phoudoin

comment:11 by vidrep, 2 years ago

This is still an issue with current builds. The user shouldn't have to go through the gymnastics of reconnecting as described above. It should be as simple as hitting the enable button. Similar related tickets which describe the same problem #9386, #13963, #12300.

comment:12 by waddlesplash, 17 months ago

Blocked By: 9695 added
Resolution: duplicate
Status: assignedclosed

The "Gateway" field is clearly unset in the first screenshot, so this is a dupe of #9695.

comment:13 by X512, 8 months ago

Still present in hrev53634.

Network access can be restored by quitting net_server from ProcessController. Reproducing sequence from #9695 is not working in my case.

Last edited 8 months ago by X512 (previous) (diff)

comment:14 by nielx, 4 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.