Opened 6 years ago

Last modified 4 weeks ago

#9695 reopened bug

Default gateway not set in certain cases

Reported by: jackburton Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/Development
Keywords: Cc:
Blocked By: #7040 Blocking: #11938
Has a Patch: no Platform: All

Description

On VirtualBox, with the Intel PRO gigabit NIC, doing the following results in a network configuration without default route.

ifconfig /dev/net/ipro1000/0 down
ifconfig /dev/net/ipro1000/0 up auto-config

Note that at startup the default route is present and is correct

Change History (6)

comment:1 Changed 6 years ago by diver

Blocked By: 7040, 9594 added

comment:2 Changed 6 years ago by diver

Blocked By: 9594 removed

Still here in hrev45736.

comment:3 Changed 5 years ago by jackburton

Resolution: fixed
Status: newclosed

comment:4 Changed 17 months ago by korli

Resolution: fixed
Status: closedreopened

Seems to still be with us. Seen in #12328 comments and reproduced locally.

comment:5 Changed 2 months ago by waddlesplash

Yep, still happens here. Especially annoying as there seems to be no way to fix this without a reboot.

Note that the "Gateway" is set in Network preferences, it's just that there is no route defined it seems.

comment:6 Changed 4 weeks ago by waddlesplash

Blocking: 11938 added
Note: See TracTickets for help on using tickets.