Opened 3 years ago

Closed 2 months ago

Last modified 12 days ago

#11947 closed bug (fixed)

Atheros on poulsbo / Nokia Booglet 3G hardware locksup haiku while boot

Reported by: streak Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet/Wireless Version: R1/Development
Keywords: atheros wifi Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Occurance: From hrev48753 to hrev48993 [last checked version]

i just checked that hrev48752 on atheros wifi works perfectly on Nokia Booklet 3G so between 48753 and 48926 [and it occurs on 48993] something was changed and wifi stopped to work [while boot it locks-up whole system, with safe fail options ON and on normal boot]

My hardware specification: Nokia Booklet 3G: Specifications: RAM: 1 GB DDR2 Hard drive: 120 GB Intel® Atom™ Z530 (1.6 GHz) Intel® Poulsbo US15W WiFi: 802.11 b/g/n Bluetooth 2.1 + EDR Built-in 3G modem (data calls only): WCDMA 900/2100 or 800-850/900/2100 1.3 megapixel FF camera HDMI 1.2 out for HD video 3 x USB 2.0 3.5 mm headphone out (OMTP: with OMTP headsets also functions as audio in) SD card reader SIM / USIM slot Accelerometer (motion sensor) Integrated A-GPS

I cant generate syslog because it doesnt even boot properly with all fail-safe options ON.

BTW. It can be releated with https://dev.haiku-os.org/ticket/11920 but im not sure..

Attachments (7)

WIN_20150405_183250.JPG (1.7 MB) - added by streak 3 years ago.
WIN_20150405_184227.JPG (1.7 MB) - added by streak 3 years ago.
WIN_20150405_184234.JPG (1.7 MB) - added by streak 3 years ago.
WIN_20150405_184845.JPG (1.5 MB) - added by streak 3 years ago.
WIN_20150405_184851.JPG (1.3 MB) - added by streak 3 years ago.
previous_syslog (130.1 KB) - added by tojoko 2 years ago.
hrev50321 without any (special) boot parameters
syslog (104.0 KB) - added by tojoko 2 years ago.
hrev50321 without atheros wifi (that one was blacklisted)

Change History (17)

Changed 3 years ago by streak

Attachment: WIN_20150405_183250.JPG added

Changed 3 years ago by streak

Attachment: WIN_20150405_184227.JPG added

Changed 3 years ago by streak

Attachment: WIN_20150405_184234.JPG added

Changed 3 years ago by streak

Attachment: WIN_20150405_184845.JPG added

Changed 3 years ago by streak

Attachment: WIN_20150405_184851.JPG added

comment:2 Changed 3 years ago by streak

Any progress on fixing this ?

comment:3 Changed 3 years ago by korli

Did you try to blacklist atheroswifi to check if the driver is at fault?

comment:4 Changed 3 years ago by streak

For now i can blacklist only directories in / dir. How to blacklist only atheros?

comment:5 Changed 3 years ago by humdinger

You can blacklist specific files, in your case add-ons/kernel/drivers/bin/atheroswifi.

comment:6 Changed 2 years ago by tojoko

streak, does it work for u and if so how are your start options / settings?

Changed 2 years ago by tojoko

Attachment: previous_syslog added

hrev50321 without any (special) boot parameters

Changed 2 years ago by tojoko

Attachment: syslog added

hrev50321 without atheros wifi (that one was blacklisted)

comment:7 Changed 23 months ago by tojoko

Please close, since no problem in hrev50629 on nokia booklet 3g, wifi workin'! No blacklistin' required anymore. Good work!

comment:8 Changed 18 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

comment:10 Changed 12 days ago by tojoko

Fix confirmed.

Note: See TracTickets for help on using tickets.