Opened 4 years ago

Closed 4 years ago

#12036 closed bug (duplicate)

Booting Haiku in VMWare causes a Page Fault Exception in the boot loader

Reported by: chrish Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: VMWare Cc:
Blocked By: #11470 Blocking:
Has a Patch: no Platform: x86

Description

Booting Haiku (tested with r1alpha4's Anyboot image and nightly .iso and Anyboot images) in VMWare Workstation 11.1.0 causes a Page Fault Exception and welcomes you to Boot Loader Death Land:

https://dl.dropboxusercontent.com/u/1412381/Haiku%20-%20VMware%20Workstation.png

Host system is a Core i7 running Windows 7 64-bit, with hardware virtualization enabled. Haiku images are the recommended 32-bit editions. Let me know what other details are useful and I'll do my best to provide them.

Attachments (2)

Haiku - VMware Workstation.png (59.1 KB) - added by chrish 4 years ago.
Boot Loader Death Land in VMWare Workstation 11
Haiku.zip (116.0 KB) - added by chrish 4 years ago.
The VMWare Workstation 11 VM I was using to generate this crash.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by chrish

Boot Loader Death Land in VMWare Workstation 11

comment:1 Changed 4 years ago by anevilyak

Milestone: UnscheduledR1

comment:2 Changed 4 years ago by waddlesplash

This might be a breakthrough for us, as we've been getting some BLDLs now and then but it's always on obscure hardware and so it's hard for us to replicate it.

What hardware did you give the guest OS? RAM? HDD space? etc. Better yet, can you upload a VMware configuration file?

comment:3 Changed 4 years ago by diver

How many CPUs do you have enabled in VM settings? #11470 might be related.

Changed 4 years ago by chrish

Attachment: Haiku.zip added

The VMWare Workstation 11 VM I was using to generate this crash.

comment:4 Changed 4 years ago by chrish

Yup, looks like #11470 is the culprit; switched it to 1 CPU/2 cores and it boots just peachy. :-)

comment:5 Changed 4 years ago by anevilyak

Blocked By: 11470 added
Resolution: duplicate
Status: newclosed

Closing as duplicate of #11470.

Note: See TracTickets for help on using tickets.