Opened 12 years ago

Closed 12 years ago

#1221 closed bug (fixed)

Spell check feature does not work in Haiku Mail app

Reported by: koki Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Mail Version: R1/pre-alpha1
Keywords: Cc: ksmith
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When you attempt to use the spell check feature in the Haiku Email app, you get the following message:

"The spell check feature requires the optional "words" file on your BeOS CD."

To reproduce:

  • Create a new email message using Haiku's Email app
  • Type some text
  • Select "Check Spelling" from "Edit" menu.

Expected behaviour:

The spell check should just work, or otherwise removed from the Email app.

Screenshot showing warning message attached.

Attachments (1)

speller-beos-cd.png (39.2 KB) - added by koki 12 years ago.
Mail app spell check warning message

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by koki

Attachment: speller-beos-cd.png added

Mail app spell check warning message

comment:1 Changed 12 years ago by ksmith

Cc: ksmith added

The spell check feature does not work because the words file does not exist. The mail app expects the words file to be located at /boot/optional/goodies/words. The words file is in the haiku source at /haiku/src/apps/mail/words but it does not get built into haiku. Placing the words file in the correct directory in haiku makes the spell check feature work like a charm.

comment:2 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev22111.

Note: See TracTickets for help on using tickets.