Opened 4 years ago

Closed 4 years ago

#12285 closed bug (fixed)

[ShowImage] deadlocks on copy selection

Reported by: Paradoxon Owned by: axeld
Priority: blocker Milestone: R1/beta1
Component: Kits/Application Kit Version: R1/Development
Keywords: clipboard Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Open a image in ShowImage, mark an area from the image Press copy and ShowImage will freeze

Attachments (2)

ShowImage-2642-debug-04-08-2015-08-19-48.report (23.3 KB) - added by Paradoxon 4 years ago.
Terminal-56836-debug-12-08-2015-16-43-44.report (10.7 KB) - added by diver 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by Paradoxon

comment:1 Changed 4 years ago by Paradoxon

Same happens to wonderbrush so it seems be an Clipboard problem

comment:2 Changed 4 years ago by diver

Milestone: UnscheduledR1
Summary: Schowimage crashes on copy[ShowImage] deadlocks on copy selection

comment:3 Changed 4 years ago by Paradoxon

It seems to hang on the SendMessage on line 210. But no idea how this can related to copying a (archived) Bitmap https://cgit.haiku-os.org/haiku/tree/src/kits/app/Clipboard.cpp#n210

comment:4 Changed 4 years ago by diver

Description: modified (diff)
Owner: changed from leavengood to axeld
Status: newassigned

Terminal deadlocks on copy (large) selection too. Related? Possibly another launch_daemon regression...

comment:5 Changed 4 years ago by humdinger

Component: Applications/ShowImageKits/Application Kit
Keywords: clipboard added

comment:6 Changed 4 years ago by axeld

Milestone: R1R1/beta1
Priority: normalblocker

Since mmlr didn't report his findings here yet: it's indeed a launch_daemon regression. The launch_daemon owns the primary communications ports of the registrar which breaks large messages that use areas to pass their data.

comment:7 Changed 4 years ago by mmlr

Resolution: fixed
Status: assignedclosed

Fixed in hrev49591.

Note: See TracTickets for help on using tickets.