Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12316 closed bug (no change required)

Helios CD Burning app crashes in Haiku

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Installed Helios 1.6 Final. Crashes on launch. Debug reports attached. There is a newer revision (1.71b2) in HaikuArchives with source files. However, it does not build (errors).

Attachments (3)

Helios-3546-debug-19-08-2015-00-48-46.report (10.6 KB) - added by vidrep 4 years ago.
Helios 1.6 user guide.pdf (720.3 KB) - added by vidrep 4 years ago.
Helios_syslog (1.9 KB) - added by vidrep 4 years ago.

Download all attachments as: .zip

Change History (17)

Changed 4 years ago by vidrep

Changed 4 years ago by vidrep

Attachment: Helios 1.6 user guide.pdf added

Changed 4 years ago by vidrep

Attachment: Helios_syslog added

comment:1 Changed 4 years ago by diver

Resolution: no change required
Status: newclosed

It was probably an application bug. I've fixed the build in https://github.com/HaikuArchives/Helios.

comment:2 Changed 4 years ago by vidrep

Thanks Diver! I'd like to see this one progress, as it was the most feature developed burning app at the time of the BeOS demise. Should future reports be directed to the Helios page on GitHub?

comment:3 Changed 4 years ago by diver

Sure. Don't know if it's worth the effort though. Helios was extremely buggy back in BeOS days and would take a lot of work to make it usable. Maybe there is a Qt Cdrecord frontend we can port?

comment:4 Changed 4 years ago by vidrep

There are a few BeOS burning apps still about - BurnItNow, Helios, CD Manager, and Melt. Plus one from Zeta - JABA. I have used all of these extensively back in BeOS days. The most stable version of Helios was 1.5, but 1.7 was more feature complete. CD Manager was limited to audio CD's. Melt had limited functionality and was butt ugly. I never liked the original BurnItNow. However, the rewrite shows much promise and for the most part is working. JABA was really nice (written in Yab), but the libzeta.so gets in the way of making it work in Haiku. Perhaps somebody at BeSly can contact the owner about a Haiku build?

comment:5 Changed 4 years ago by vidrep

Diver,

<Not-6fa5> [haikuports] diversys 5b083eb - Helios: add recipe for version 1.7.2

Any details on this from IRC?

comment:6 Changed 4 years ago by diver

Not really, just a recipe for this version.

comment:7 Changed 4 years ago by vidrep

Did anything change to warrant a new revision number, or are you just creating the recipe for when/if some of the outstanding issues are fixed and incorporated into the build?

comment:8 Changed 4 years ago by diver

No, nothing changed. TBH, I doubt anyone would touch the code as the app needs a complete rewrite to be usable. There is Application1.cpp which is ~5000 LoC. I just bumped version to indicate that it now compiles/sort of works on Haiku, nothing else :)

comment:9 Changed 4 years ago by vidrep

Sorry for using this ticket as a channel of communication (no access to IRC from work). Since Helios is basically a FUBAR as far as using it in Haiku, and no other decent burning app exists outside of BurnItNow, how about reopening ticket #1098 and tracking bugs and enhancements for it there? Since BeOS R5 had a native cd burner app, why not make BurnItNow the replacement?

comment:10 Changed 4 years ago by pulkomandy

Why would we track bug and enhancements on Haiku bug tracker for an app that isn't developed by the Haiku team? Why not use burnitnow own bugtracker at https://github.com/haikuarchives/burnitnow/issues ?

It looks like some of the tasks there could be solved during the Google Code-In. Maybe we can also get one student to split Helios in smaller files.

comment:11 Changed 4 years ago by vidrep

I have already filed a half-dozen bug reports for BurnItNow at github - zero feedback in two months. Remember how it took 3 years before CDRecord finally was fixed? So, I guess that's progress. I guess I will be using the command line to burn CD's for the foreseeable future, provided I'm quick enough to grab the drawer for my optical drive due to the recently introduced AHCI reset bug.

comment:12 Changed 4 years ago by pulkomandy

The AHCI problems are something we will take care of on Haiku side, eventually (at least this one I can reproduce on one of my machines).

I noticed there are some tickets from you on burnitnow, and as I said, we will put these up as GCI tasks, as they are a good fit there (for their size and difficulty). There is no point in tracking everything on Haiku bugtracker, there are too much ticket here and the problems just get lost, so splitting app-specific problems to the application's bug trackers make the situation (slightly) better.

comment:13 Changed 4 years ago by vidrep

Thanks for the clarification. So, should I continue with bug reports and end-user enhancement suggestions for BurnItNow (and other apps which I try to use)? I know there are more pressing problems with the main Haiku distribution that the limited time of the developers is better spent addressing.

comment:14 Changed 4 years ago by pulkomandy

yes, even if the bugreports aren't fixed immediately, it helps knowing what state the app is in. Then, either we turn them into GCI tasks, or someone will take the time to fix them. If I ever need to burn a CD, I will take a look at one of these, and if all the bugs are already open, I'll probably spend the rest of the day fixing at least some. Otherwise, once I've managed to burn my CD, I'll move to something else. So, testing the apps and listing the bugs is a great help for us developers, it means we can just sit down and fix the things one after the other, without having to track the problems first. Of course, good bug reports (with debugger stack trace, steps to reproduce, etc) are better. This is a good way to contribute to Haiku, thanks for doing it!

Note: See TracTickets for help on using tickets.