Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12323 closed bug (duplicate)

Boot freezes at rocket icon in anyboot image booted from USB stick

Reported by: alalalan Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #2539 Blocking:
Has a Patch: no Platform: x86

Description

Hi, I'm new to the project (and bug reporting in general) and am just testing it out. I consider myself pretty tech-savvy but I don't actually know any programming. I will stick around to help/ask for help with resolving this bug. It's probably a duplicate (there are a lot of boot failure issues reported) but I figured I'd share my experence if the details can help overall. Hopefully it isn't too irrelevant.

Haiku version tested: haiku-nightly-hrev49559-x86_gcc2_hybrid-anyboot.image

Setup

  • Asus EeePC 1025CE netbook
    • Onboard sound card (broken) and bluetooth (never used) disabled in BIOS
    • Aside: I also tried disabling wifi and ethernet in BIOS but these boots were still unsuccessful (syslogs not recorded)
  • FAT32 SD card to record syslogs
  • USB stick contains the above Haiku image written from Windows 7 using ImageWriter.

Notes, roughly sorted by decreasing relevance of the details This does not seem to be a regression caused by launch_daemon; I tried using a nightly image from before launch_daemon was added (hrev49424) and it also would not boot (syslogs not recorded).

Previously, I used the SD card to boot the Haiku image (syslogs not recorded) with similar results, and switched the image to the USB disk in order to make sure it wasn't a problem with the SD card itself.

I recorded the syslogs of four boots in order. I waited a few minutes during each boot, then powered off the system manually with the power button because all four attempts froze, so it's possible that there is some unrecorded output at the very end. The boot settings used for each of the four boots are as follows:

  • SYSLOG0.TXT: attempted boot with default options
  • SYSLOG1.TXT: attempted boot with all safe mode options checked
  • SYSLOG2.TXT: attempted boot with video mode 800x600x16
  • SYSLOG3.TXT: attempted boot with video mode 800x600x16 + all safe mode options checked

Another interesting/frustrating detail is that there have been a couple times times when Haiku managed to start up using the 16-bit video modes (forgot to save the syslogs of the successful boots). However, the system always froze after a few seconds or minutes, and then on halting and booting up the system again it would go back to freezing on the rocket icon. This might belong to another bug report but I'm including it here in case the freezing is caused by the same problem. Or perhaps it is user error/hardware failure, although I'm able to can run Linux distributions indefinitely with the same USB stick and SD card.

Adding on to the above detail, if I have on screen debug output enabled, the on screen debug output will always freeze (somtimes the syslogs will continue recording past where the output freezes) and Haiku will not boot regardless of video mode. I did not enable on screen debug output in the above four boots so I have not recorded what the syslogs produce in this case. Between this and the above paragraph I suspect it might be a video card issue.

Also attached are a list of hardware devices as output from a Linux distro (lshw, lspci, lsusb), since for obvious reasons I could not include listdev, listusb from Haiku. There are some differences in the hardware between when I ran these Linux commands and when I produced the attached syslogs (which I did after running the Linux commands):

  • As shown in the lshw, USB stick contained the Linux distro and the SD card contained the Haiku image, but I switched this around (see "Previously," paragraph)
  • lsusb shows a b58e:9e84, which is a USB microphone that I'm using in place of my broken sound card. I removed the microphone before booting up Haiku.

I will also mention that I could not produce ints output because I've never seen or have been able to invoke the KDL, although I expected this because I doubt the netbook keyboard is PS/2.

Attachments (8)

SYSLOG00.TXT (95.0 KB) - added by alalalan 4 years ago.
Syslog of attempted boot with default boot options
SYSLOG01.TXT (86.9 KB) - added by alalalan 4 years ago.
syslog of boot with all safe mode options selected
SYSLOG02.TXT (77.1 KB) - added by alalalan 4 years ago.
syslog of boot with video mode 800x600x16 selected
SYSLOG03.TXT (86.6 KB) - added by alalalan 4 years ago.
syslog of boot with video mode 800x600x16 + all safe mode options checked (mostly identical to SYSLOG01.TXT)
lshw.txt (14.2 KB) - added by alalalan 4 years ago.
Linux output of computer's hardware
lspci.txt (1.3 KB) - added by alalalan 4 years ago.
Linux output of PCI devices
lsusb.txt (615 bytes) - added by alalalan 4 years ago.
Linux output of USB devices
SYSLOG04.TXT (157.0 KB) - added by alalalan 4 years ago.
one syslog of boot with 800x600x16 + Fail-safe video mode selected

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by alalalan

Attachment: SYSLOG00.TXT added

Syslog of attempted boot with default boot options

Changed 4 years ago by alalalan

Attachment: SYSLOG01.TXT added

syslog of boot with all safe mode options selected

Changed 4 years ago by alalalan

Attachment: SYSLOG02.TXT added

syslog of boot with video mode 800x600x16 selected

Changed 4 years ago by alalalan

Attachment: SYSLOG03.TXT added

syslog of boot with video mode 800x600x16 + all safe mode options checked (mostly identical to SYSLOG01.TXT)

Changed 4 years ago by alalalan

Attachment: lshw.txt added

Linux output of computer's hardware

Changed 4 years ago by alalalan

Attachment: lspci.txt added

Linux output of PCI devices

Changed 4 years ago by alalalan

Attachment: lsusb.txt added

Linux output of USB devices

comment:1 Changed 4 years ago by diver

Component: SystemServers/app_server
Owner: changed from nobody to axeld

All syslogs (except SYSLOG02.TXT) indicates a crash in app_server during start up. Does booting in 800x600x16 + Fail-safe video mode change anything?

comment:2 Changed 4 years ago by alalalan

No, it remains stuck at the rocket icon. I tried booting twice, giving each boot a few minutes of time. The end of first boot attempt's syslog is similar to SYSLOG03.TXT minus the "Running post install script" messages. The second boot's syslog has several additional messages relating to atheroswifi that I doubt are relevant, but I'll include the syslog just in case (attached as SYSLOG04.TXT). Both of them also indicate a crash in app_server.

Changed 4 years ago by alalalan

Attachment: SYSLOG04.TXT added

one syslog of boot with 800x600x16 + Fail-safe video mode selected

comment:3 Changed 4 years ago by diver

Same crash in app_server there... Try other video modes maybe?

comment:4 Changed 4 years ago by diver

Blocked By: 2539 added
Resolution: duplicate
Status: newclosed

Most likely a duplicate of #2539.

comment:5 Changed 4 years ago by alalalan

Thanks for identifying the problem and closing the bug. The other video modes also crash there. It might be crashing at boot because the native resolution of the netbook is 1024x600 and the only VESA modes available are in 800x600 and 600x480.

Note: See TracTickets for help on using tickets.