Opened 12 years ago

Closed 12 years ago

#1240 closed bug (fixed)

BTextView and BScrollView: - Selection and drag moves text

Reported by: katisu Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: katisu@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Initially ran into this problem when looking at the print kit. The PCL6 driver has an additional "add printer" dialog that has a description area. If the text in this area is selected and the mouse dragged the text moves in the opposite direction. The first picture shows it in that dialog. This does not happen on hrev5.

The problem is also reproducible with the About This System (formerly AboutHaiku) dialog. Second picture shows it in this dialog.

Attachments (2)

Image3.png (14.4 KB) - added by katisu 12 years ago.
Selection and drag in add printer dialog for PCL6
Image4.png (26.5 KB) - added by katisu 12 years ago.
Selection and drag in About This System

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by katisu

Attachment: Image3.png added

Selection and drag in add printer dialog for PCL6

Changed 12 years ago by katisu

Attachment: Image4.png added

Selection and drag in About This System

comment:1 Changed 12 years ago by jackburton

Component: Servers/app_serverKits/Interface Kit
Owner: changed from axeld to jackburton

comment:2 Changed 12 years ago by jackburton

Status: newassigned

Should be fixed in hrev21207. Can you check ?

comment:3 Changed 12 years ago by katisu

Problem is fixed.

comment:4 Changed 12 years ago by jackburton

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.